[bug#54686] gnu: nss-certs: Use G-Expression.
Commit Message
This fixes cross-compilation for aarch64-linux-gnu.
* gnu/packages/certs.scm (nss-certs)[arguments]: Use a gexp to remove
references to %output.
---
gnu/packages/certs.scm | 31 ++++++++++++++++---------------
1 file changed, 16 insertions(+), 15 deletions(-)
Comments
Hi,
Brian Kubisiak <brian@kubisiak.com> skribis:
> This fixes cross-compilation for aarch64-linux-gnu.
>
> * gnu/packages/certs.scm (nss-certs)[arguments]: Use a gexp to remove
> references to %output.
I resolved the merge conflict and applied to ‘staging’ (the
cross-compilation issue was fixed in
5389c5ea57dd17e19412f38dc448b0a5114a3579.)
Thanks,
Ludo’.
@@ -28,6 +28,7 @@ (define-module (gnu packages certs)
#:use-module (guix packages)
#:use-module (guix utils)
#:use-module (guix download)
+ #:use-module (guix gexp)
#:use-module (guix git-download)
#:use-module (guix build-system copy)
#:use-module (guix build-system gnu)
@@ -164,21 +165,21 @@ (define-public nss-certs
(rnrs io ports)
(srfi srfi-26))
#:phases
- (modify-phases
- (map (cut assq <> %standard-phases)
- '(set-paths install-locale unpack))
- (add-after 'unpack 'install
- (lambda _
- (let ((certsdir (string-append %output "/etc/ssl/certs/")))
- (with-directory-excursion "nss/lib/ckfw/builtins/"
- (unless (file-exists? "blacklist.txt")
- (call-with-output-file "blacklist.txt" (const #t)))
- ;; Extract selected single certificates from blob.
- (invoke "certdata2pem")
- ;; Copy .pem files into the output.
- (for-each (cut install-file <> certsdir)
- (find-files "." ".*\\.pem$")))
- (invoke "openssl" "rehash" certsdir)))))))
+ ,#~(modify-phases
+ (map (cut assq <> %standard-phases)
+ '(set-paths install-locale unpack))
+ (add-after 'unpack 'install
+ (lambda _
+ (let ((certsdir (string-append #$output "/etc/ssl/certs/")))
+ (with-directory-excursion "nss/lib/ckfw/builtins/"
+ (unless (file-exists? "blacklist.txt")
+ (call-with-output-file "blacklist.txt" (const #t)))
+ ;; Extract selected single certificates from blob.
+ (invoke "certdata2pem")
+ ;; Copy .pem files into the output.
+ (for-each (cut install-file <> certsdir)
+ (find-files "." ".*\\.pem$")))
+ (invoke "openssl" "rehash" certsdir)))))))
(synopsis "CA certificates from Mozilla")
(description
"This package provides certificates for Certification Authorities (CA)