diff mbox series

[bug#54676] gnu: Fix plocate package

Message ID 20220401213204.29639-1-mail@ykonai.net
State Accepted
Headers show
Series [bug#54676] gnu: Fix plocate package | expand

Commit Message

ykonai April 1, 2022, 9:32 p.m. UTC
* gnu/packages/search.scm (plocate): Change build options.
---
Current plocate package sets the --sharedstatedir to a store directory, which
causes updatedb and plocate to fail by default since the store is immutable.
This will set the default database path to /var/cache/plocate.db instead.

 gnu/packages/search.scm | 13 +++++++++++--
 1 file changed, 11 insertions(+), 2 deletions(-)


base-commit: a27cef76c29ba6ef0d7c203783b758ea2d5331d7

Comments

Ludovic Courtès April 5, 2022, 6:32 p.m. UTC | #1
Hi,

ykonai <mail@ykonai.net> skribis:

> * gnu/packages/search.scm (plocate): Change build options.

Applied, thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/search.scm b/gnu/packages/search.scm
index 6f8d673694..87f29c5424 100644
--- a/gnu/packages/search.scm
+++ b/gnu/packages/search.scm
@@ -487,8 +487,17 @@  (define-public plocate
     (arguments
      `(#:configure-flags
        (list
-        (string-append
-         "--sharedstatedir=" (assoc-ref %outputs "out") "/var"))))
+        ;; Put the database in /var/cache/plocate.db
+        "--sharedstatedir=/var"
+        "-Dinstall_systemd=false"
+        "-Ddbpath=cache/plocate.db")
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'remove-cachedirtag
+           (lambda _
+             (substitute* "meson.build"
+               ;; Remove the script adding a "cachedirtag"
+               (("meson.add_install_script") "#")))))))
     (inputs
      (list liburing
            `(,zstd "lib")))