diff mbox series

[bug#54645,v2] gnu: emacs-elpy: Update to 1746e70.

Message ID 20220331143304.6063-1-jgart@dismail.de
State Accepted
Headers show
Series [bug#54645,v2] gnu: emacs-elpy: Update to 1746e70. | expand

Commit Message

jgart March 31, 2022, 2:33 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-elpy): Update to 1746e70.

Using the latest commit fixes outstanding bugs such as the following:
https://github.com/jorgenschaefer/elpy/issues/1824
https://github.com/jorgenschaefer/elpy/pull/1951
https://github.com/jorgenschaefer/elpy/issues/1940

Hi Maxime,

Thanks for the review.

I added a comment on some of the fixes that are provided by using the latest current commit.

The previous version (8d0de31) of emacs-elpy was also using the latest commit at the time.

There was a comment about it in the let block.

WDYT?

all best,

jgart

---
 gnu/packages/emacs-xyz.scm | 12 +++++++-----
 1 file changed, 7 insertions(+), 5 deletions(-)

Comments

Maxim Cournoyer April 4, 2022, 3:56 a.m. UTC | #1
Hello,

jgart <jgart@dismail.de> writes:

> * gnu/packages/emacs-xyz.scm (emacs-elpy): Update to 1746e70.
>
> Using the latest commit fixes outstanding bugs such as the following:
> https://github.com/jorgenschaefer/elpy/issues/1824
> https://github.com/jorgenschaefer/elpy/pull/1951
> https://github.com/jorgenschaefer/elpy/issues/1940
>
> Hi Maxime,
>
> Thanks for the review.
>
> I added a comment on some of the fixes that are provided by using the latest current commit.
>
> The previous version (8d0de31) of emacs-elpy was also using the latest commit at the time.
>
> There was a comment about it in the let block.
>
> WDYT?

LGTM.  Applied as 75371f952fd800bda7e8c2fe5dac5a4fd0f87d70.  Thank you!

Closing.

Maxim
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index b733adc02f..beda1126c5 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -10847,10 +10847,12 @@  (define-public emacs-highlight-indentation
       (license license:gpl2+))))
 
 (define-public emacs-elpy
-  ;; Use the latest commit, as it contains unreleased fixes for Python 3.9 and
-  ;; Jedi 0.18.
-  (let ((commit "8d0de310d41ebf06b22321a8534546447456870c")
-        (revision "0"))
+  ;; Using the latest commit fixes outstanding bugs such as the following:
+  ;; https://github.com/jorgenschaefer/elpy/issues/1824
+  ;; https://github.com/jorgenschaefer/elpy/pull/1951
+  ;; https://github.com/jorgenschaefer/elpy/issues/1940
+  (let ((commit "1746e7009000b7635c0ea6f1559018143aa61642")
+        (revision "1"))
     (package
       (name "emacs-elpy")
       (version (git-version "1.35.0" revision commit))
@@ -10862,7 +10864,7 @@  (define-public emacs-elpy
                 (file-name (git-file-name name version))
                 (sha256
                  (base32
-                  "0hg6yk0wkfh2rwcc4h0bb6m2p3dg62ja22mjpa94khq52lv1piwf"))))
+                  "120xzzaa8jxls3lri6d53zq6gafnkc6d9mlg09an334kkmh8k2fc"))))
       (build-system emacs-build-system)
       (arguments
        `(#:include (cons* "^elpy/[^/]+\\.py$" "^snippets\\/" %default-include)