diff mbox series

[bug#54635,v2,3/5] gnu: atomic-queue: Run tests correctly.

Message ID 20220331072849.22417-3-arunisaac@systemreboot.net
State Accepted
Headers show
Series [bug#54635,v2,1/5] gnu: gsl: Force bootstrap when cross-compiling to riscv64-linux. | expand

Commit Message

Arun Isaac March 31, 2022, 7:28 a.m. UTC
* gnu/packages/cpp.scm (atomic-queue)[arguments]: In the check phase, run
tests instead of returning a function to run them.
---
 gnu/packages/cpp.scm | 3 +--
 1 file changed, 1 insertion(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index bb7f5ab95a..eb48902034 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -1297,8 +1297,7 @@  (define-public atomic-queue
          (replace 'check
            (lambda* (#:key tests? #:allow-other-keys)
              (when tests?
-               (lambda _
-                 (invoke "make" "run_tests")))))
+               (invoke "./tests"))))
          (replace 'install
            (lambda* (#:key outputs #:allow-other-keys)
              (copy-recursively "../source/include/atomic_queue"