diff mbox series

[bug#54645] gnu: emacs-elpy: Update to 1746e70.

Message ID 20220331025250.23435-1-jgart@dismail.de
State Accepted
Headers show
Series [bug#54645] gnu: emacs-elpy: Update to 1746e70. | expand

Commit Message

jgart March 31, 2022, 2:52 a.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-elpy): Update to 1746e70.
[arguments]: Remove #:tests? keyword statement set to true.
---
 gnu/packages/emacs-xyz.scm | 7 +++----
 1 file changed, 3 insertions(+), 4 deletions(-)

Comments

Maxim Cournoyer March 31, 2022, 3 a.m. UTC | #1
Hello!

jgart <jgart@dismail.de> writes:

> * gnu/packages/emacs-xyz.scm (emacs-elpy): Update to 1746e70.
> [arguments]: Remove #:tests? keyword statement set to true.
> ---
>  gnu/packages/emacs-xyz.scm | 7 +++----
>  1 file changed, 3 insertions(+), 4 deletions(-)
>
> diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
> index f8a44a1fef..5250933a7f 100644
> --- a/gnu/packages/emacs-xyz.scm
> +++ b/gnu/packages/emacs-xyz.scm
> @@ -10849,8 +10849,8 @@ (define-public emacs-highlight-indentation
>  (define-public emacs-elpy
>    ;; Use the latest commit, as it contains unreleased fixes for Python 3.9 and
>    ;; Jedi 0.18.
> -  (let ((commit "8d0de310d41ebf06b22321a8534546447456870c")

Is there some worthy fixes in this latest version?  If there are, the
comment giving the rationale for not using the stable release should be
updated to reflect why using the latest commit is necessary.

Thank you,

Maxim
M March 31, 2022, 12:03 p.m. UTC | #2
jgart via Guix-patches via schreef op wo 30-03-2022 om 22:52 [-0400]:
> -         #:tests? #t

Please keep this, because tests are not run by default for emacs-build-
system. (emacs-build-system is a bit of an exception)

Greetings,
Maxime.
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index f8a44a1fef..5250933a7f 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -10849,8 +10849,8 @@  (define-public emacs-highlight-indentation
 (define-public emacs-elpy
   ;; Use the latest commit, as it contains unreleased fixes for Python 3.9 and
   ;; Jedi 0.18.
-  (let ((commit "8d0de310d41ebf06b22321a8534546447456870c")
-        (revision "0"))
+  (let ((commit "1746e7009000b7635c0ea6f1559018143aa61642")
+        (revision "1"))
     (package
       (name "emacs-elpy")
       (version (git-version "1.35.0" revision commit))
@@ -10862,7 +10862,7 @@  (define-public emacs-elpy
                 (file-name (git-file-name name version))
                 (sha256
                  (base32
-                  "0hg6yk0wkfh2rwcc4h0bb6m2p3dg62ja22mjpa94khq52lv1piwf"))))
+                  "120xzzaa8jxls3lri6d53zq6gafnkc6d9mlg09an334kkmh8k2fc"))))
       (build-system emacs-build-system)
       (arguments
        `(#:include (cons* "^elpy/[^/]+\\.py$" "^snippets\\/" %default-include)
@@ -10904,7 +10904,6 @@  (define-public emacs-elpy
                  (mkdir-p man1)
                  (copy-file "docs/_build/man/elpy.1"
                             (string-append man1 "/elpy.1"))))))
-         #:tests? #t
          #:test-command '("ert-runner")))
       (propagated-inputs
        (list emacs-company