diff mbox series

[bug#54525,v2,3/5] gnu: Add thunar-media-tags-plugin.

Message ID 20220329130402.26022-3-tumashu@163.com
State New
Headers show
Series [bug#54525,v2,1/5] gnu: Add thunar-archive-plugin. | expand

Commit Message

Feng Shu March 29, 2022, 1:04 p.m. UTC
From: Feng Shu <tumashu@163.com>

* gnu/packages/xfce.scm (thunar-media-tags-plugin): New variable.
---
 gnu/packages/xfce.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index 8bfa3a9422..44d34cab8f 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -52,6 +52,7 @@  (define-module (gnu packages xfce)
   #:use-module (gnu packages libcanberra)
   #:use-module (gnu packages linux)
   #:use-module (gnu packages mate)
+  #:use-module (gnu packages mp3)
   #:use-module (gnu packages pcre)
   #:use-module (gnu packages pdf)
   #:use-module (gnu packages photo)
@@ -835,6 +836,28 @@  (define-public thunar-shares-plugin
 Samba from Thunar (the Xfce file manager) without requiring root access.")
     (license gpl2+)))
 
+(define-public thunar-media-tags-plugin
+  (package
+    (name "thunar-media-tags-plugin")
+    (version "0.3.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://archive.xfce.org/src/thunar-plugins/"
+                           name "/" (version-major+minor version)
+                           "/" name "-" version ".tar.bz2"))
+       (sha256
+        (base32 "06sr7b4p9f585gian8vpx7j0pkzg0vvwcrjmrhvh7i5sb90w8rg2"))))
+    (build-system gnu-build-system)
+    (native-inputs (list pkg-config intltool))
+    (inputs (list exo gtk+ thunar taglib))
+    (home-page "https://www.xfce.org/")
+    (synopsis "Media tags plugin for Thunar file manager")
+    (description
+     "Media tags plugin allows tags editing from Thunar file manager and
+tags-based file renaming from inside Thunar Bulk Renamer.")
+    (license gpl2+)))
+
 (define-public xfwm4
   (package
     (name "xfwm4")