diff mbox series

[bug#54525,v2,2/5] gnu: Add thunar-shares-plugin.

Message ID 20220329130402.26022-2-tumashu@163.com
State New
Headers show
Series [bug#54525,v2,1/5] gnu: Add thunar-archive-plugin. | expand

Commit Message

Feng Shu March 29, 2022, 1:03 p.m. UTC
From: Feng Shu <tumashu@163.com>

* gnu/packages/xfce.scm (thunar-shares-plugin): New variable.
---
 gnu/packages/xfce.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index 1b0e262735..8bfa3a9422 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -813,6 +813,28 @@  (define-public thunar-archive-plugin
 archive files using the file context menus in the Thunar file manager.")
     (license gpl2+)))
 
+(define-public thunar-shares-plugin
+  (package
+    (name "thunar-shares-plugin")
+    (version "0.3.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://archive.xfce.org/src/thunar-plugins/"
+                           name "/" (version-major+minor version)
+                           "/" name "-" version ".tar.bz2"))
+       (sha256
+        (base32 "182j8jl91735004hbl0i2xxga4r6fk03srfl6g87czkjm9y8q7fw"))))
+    (build-system gnu-build-system)
+    (native-inputs (list pkg-config intltool))
+    (inputs (list thunar gtk+))
+    (home-page "https://www.xfce.org/")
+    (synopsis "Folder share plugin for Thunar file manager")
+    (description
+     "The Thunar Shares Plugin allows you to quickly share a folder using
+Samba from Thunar (the Xfce file manager) without requiring root access.")
+    (license gpl2+)))
+
 (define-public xfwm4
   (package
     (name "xfwm4")