diff mbox series

[bug#49672,v2,2/6] gnu: libgc: Use default argument in ‘target-hurd?’ call

Message ID 20220327214026.102723-3-bauermann@kolabnow.com
State New
Headers show
Series Target check fixes for cross compilation | expand

Commit Message

Thiago Jung Bauermann March 27, 2022, 9:40 p.m. UTC
‘%current-system’ is always defined, so the expression
“(or (%current-system) (%current-target-system))” is equivalent to
“(%current-system)”, which is unlikely to be the intent of the code.

The default argument for ‘target-hurd?’ has the ‘or’ expression in the
correct order, so just use that.

* gnu/packages/bdw-gc.scm (libgc)[arguments]<#:configure-flags>: Omit
argument in call to ‘target-hurd?’.
---
 gnu/packages/bdw-gc.scm | 3 +--
 1 file changed, 1 insertion(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/bdw-gc.scm b/gnu/packages/bdw-gc.scm
index 2698d56da00b..13a6691db4b2 100644
--- a/gnu/packages/bdw-gc.scm
+++ b/gnu/packages/bdw-gc.scm
@@ -56,8 +56,7 @@  (define-public libgc
        ;; to configure script. See bug report and discussion:
        ;; <https://lists.opendylan.org/pipermail/bdwgc/2017-April/006275.html>
        ;; <https://lists.gnu.org/archive/html/bug-hurd/2017-01/msg00008.html>
-       ,@(if (target-hurd? (or (%current-system)
-                               (%current-target-system)))
+       ,@(if (target-hurd?)
              '("--disable-gcj-support")
              '()))))
    (native-inputs (list pkg-config))