diff mbox series

[bug#54590,1/4] gnu: ghc-http-client: Update to 0.7.11.

Message ID 20220327032604.475598-1-kyle@kyleam.com
State Accepted
Headers show
Series Update git-annex to 10.20220322 | expand

Commit Message

Kyle Meyer March 27, 2022, 3:26 a.m. UTC
* gnu/packages/haskell-web.scm (ghc-http-client): Update to 0.7.11.
[inputs]: Add ghc-iproute.
---
 gnu/packages/haskell-web.scm | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-web.scm b/gnu/packages/haskell-web.scm
index 70a4eccce6..470a0a02be 100644
--- a/gnu/packages/haskell-web.scm
+++ b/gnu/packages/haskell-web.scm
@@ -221,7 +221,7 @@  (define-public ghc-http
 (define-public ghc-http-client
   (package
     (name "ghc-http-client")
-    (version "0.6.4.1")
+    (version "0.7.11")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://hackage.haskell.org/package/"
@@ -229,7 +229,7 @@  (define-public ghc-http-client
                                   version ".tar.gz"))
               (sha256
                (base32
-                "1y12xfh6xvsfvyapbssmgrpjz025rmyccprbnmzhs0y1cmlz6hjp"))))
+                "12j7vkpkm2djws6ny7vm2324c7916d0iaf1mbvf4mfjxzy2w7imv"))))
     (build-system haskell-build-system)
     ;; Tests require access to the web.
     (arguments `(#:tests? #f))
@@ -242,6 +242,7 @@  (define-public ghc-http-client
            ghc-data-default-class
            ghc-exceptions
            ghc-http-types
+           ghc-iproute
            ghc-memory
            ghc-mime-types
            ghc-monad-control