diff mbox series

[bug#54584] gnu: python-slixmpp: Update to 1.8.1.

Message ID 20220326182743.23277-1-jgart@dismail.de
State New
Headers show
Series [bug#54584] gnu: python-slixmpp: Update to 1.8.1. | expand

Commit Message

jgart March 26, 2022, 6:27 p.m. UTC
* gnu/packages/python-xyz.scm (python-slixmpp): Update to 1.8.1.
[arguments]: Remove trailing boolean and use new style.
---
 gnu/packages/python-xyz.scm | 19 +++++++++----------
 1 file changed, 9 insertions(+), 10 deletions(-)

Comments

M March 26, 2022, 9:16 p.m. UTC | #1
jgart via Guix-patches via schreef op za 26-03-2022 om 14:27 [-0400]:
> +      (list #:phases
> +            #~(modify-phases %standard-phases
> +                (add-after 'unpack 'patch
> +                  (lambda _
> +                    (substitute* "setup.py"
> +                      (("'CC', 'cc'")
> +                       "'CC', 'gcc'")))))))

I now this was present in the original code, but this is most likely
completely broken when cross-compiling.  Use cc-for-target instead.
Additionally, you can try removing input labels from 'native-inputs'.

Greetings,
Maxime.
Vagrant Cascadian Sept. 1, 2023, 11:41 p.m. UTC | #2
On 2022-03-26, jgart wrote:
> * gnu/packages/python-xyz.scm (python-slixmpp): Update to 1.8.1.
> [arguments]: Remove trailing boolean and use new style.

This was updated to a newer version in:

3b57f25f55c52c97428106de285d3cf2746554dc gnu: python-slixmpp: Update to 1.8.3.

Marking as done.

live well,
  vagrant
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ae335cc83f..bebd931bb1 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -688,7 +688,7 @@  (define-public python-mkdocs-material
 (define-public python-slixmpp
   (package
     (name "python-slixmpp")
-    (version "1.5.2")
+    (version "1.8.1")
     (source
      (origin
        (method git-fetch)
@@ -700,17 +700,16 @@  (define-public python-slixmpp
        (file-name
         (git-file-name name version))
        (sha256
-        (base32 "15mqxcws14bjvh5jcfwl86zsvrymkdw3ya07vb44md7vfnsnclwx"))))
+        (base32 "0723m7pbyf4xnsy381drni3kr8wm60637gn6d7fbf4i5m04jy9iy"))))
     (build-system python-build-system)
     (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'patch
-           (lambda _
-             (substitute* "setup.py"
-               (("'CC', 'cc'")
-                "'CC', 'gcc'"))
-             #t)))))
+      (list #:phases
+            #~(modify-phases %standard-phases
+                (add-after 'unpack 'patch
+                  (lambda _
+                    (substitute* "setup.py"
+                      (("'CC', 'cc'")
+                       "'CC', 'gcc'")))))))
     (native-inputs
      `(("cython" ,python-cython)
        ("gnupg" ,gnupg)