diff mbox series

[bug#54575] gnu: Add xfce4-dict.

Message ID 20220326020431.13924-1-tumashu@163.com
State Accepted
Headers show
Series [bug#54575] gnu: Add xfce4-dict. | expand

Commit Message

Feng Shu March 26, 2022, 2:04 a.m. UTC
From: Feng Shu <tumashu@163.com>

* gnu/packages/xfce.scm (xfce4-dict): New variable.
---
 gnu/packages/xfce.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)

Comments

Ludovic Courtès March 29, 2022, 9:34 a.m. UTC | #1
Hi,

tumashu@163.com skribis:

> From: Feng Shu <tumashu@163.com>
>
> * gnu/packages/xfce.scm (xfce4-dict): New variable.

Applied, thanks!

Ludo’.
Ludovic Courtès March 29, 2022, 9:36 a.m. UTC | #2
tumashu@163.com skribis:

> From: Feng Shu <tumashu@163.com>
>
> * gnu/packages/xfce.scm (xfce4-dict): New variable.

[...]

> +    (license gpl2)))

I changed that to ‘gpl2+’ since source file headers carry the “or any
later version” wording.

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index ee8ac4f007..9b8fc6c36b 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -976,6 +976,35 @@  (define-public xfce4-terminal
 on your desktop.")
     (license gpl2+)))
 
+(define-public xfce4-dict
+  (package
+    (name "xfce4-dict")
+    (version "0.8.4")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://archive.xfce.org/src/apps/" name "/"
+                                  (version-major+minor version) "/"
+                                  name "-" version ".tar.bz2"))
+              (sha256
+               (base32
+                "1qriyvii50v8a8dx7aw6nlm888mf5cjrb9nwm3r0dcs2yzxzx1fb"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     (list intltool pkg-config))
+    (inputs
+     (list libxfce4ui xfce4-panel))
+    (home-page "https://www.xfce.org/")
+    (synopsis "Dictionary of Xfce desktop")
+    (description
+     "Xfce4-dict allows you to search different kinds of dictionary services
+for words or phrases and shows you the result.  Currently you can query a Dict
+server (RFC 2229), any online dictionary service by opening a web browser or
+search for words using the aspell/ispell program.
+
+xfce4-dict contains a stand-alone application called “xfce4-dict” and a panel
+plugin for the Xfce panel.")
+    (license gpl2)))
+
 (define-public xfdashboard
   (package
     (name "xfdashboard")