[bug#54576] gnu: dnsmasq: Fix cross-compilation.
Commit Message
* gnu/packages/dns.scm (dnsmasq)[arguments]: Use PKG-CONFIG-FOR-TARGET.
---
gnu/packages/dns.scm | 1 +
1 file changed, 1 insertion(+)
Comments
> * gnu/packages/dns.scm (dnsmasq)[arguments]: Use PKG-CONFIG-FOR-TARGET.
Pushed, thanks!
Mathieu
@@ -309,6 +309,7 @@ (define-public dnsmasq
(modify-phases %standard-phases (delete 'configure))
#:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
(string-append "CC=" ,(cc-for-target))
+ (string-append "PKG_CONFIG=" ,(pkg-config-for-target))
"COPTS=\"-DHAVE_DBUS\"")
#:tests? #f)) ; no ‘check’ target
(home-page "http://www.thekelleys.org.uk/dnsmasq/doc.html")