diff mbox series

[bug#54573] gnu: Add xfdashboard.

Message ID 20220326012209.1725-1-tumashu@163.com
State Accepted
Headers show
Series [bug#54573] gnu: Add xfdashboard. | expand

Commit Message

Feng Shu March 26, 2022, 1:22 a.m. UTC
From: Feng Shu <tumashu@163.com>

* gnu/packages/xfce.scm (xfdashboard): New variable.
---
 gnu/packages/xfce.scm | 38 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 38 insertions(+)

Comments

宋文武 March 26, 2022, 3:58 a.m. UTC | #1
tumashu@163.com writes:

> From: Feng Shu <tumashu@163.com>
>
> * gnu/packages/xfce.scm (xfdashboard): New variable.

Applied, with:
1. Move 'glib:bin' to native-inputs.
2. Change license to 'gpl2+'.

Thank you!
diff mbox series

Patch

diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index 76f904d423..ee8ac4f007 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -976,6 +976,44 @@  (define-public xfce4-terminal
 on your desktop.")
     (license gpl2+)))
 
+(define-public xfdashboard
+  (package
+    (name "xfdashboard")
+    (version "0.8.1")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://archive.xfce.org/src/apps/" name "/"
+                                  (version-major+minor version) "/"
+                                  name "-" version ".tar.bz2"))
+              (sha256
+               (base32
+                "1xfyli91gpw7bn9gjk6gp8lnn50qsjd5lh5mzypz9kx3l88wbas4"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     (list intltool pkg-config))
+    (inputs
+     (list clutter
+           garcon
+           (list glib "bin")
+           gtk+
+           libwnck
+           libxcomposite
+           libxdamage
+           libxfce4util
+           libxfce4ui
+           libxinerama
+           xfconf))
+    (home-page "https://www.xfce.org/")
+    (synopsis "Gnome shell like dashboard for Xfce")
+    (description
+     "Xfdashboard provides a GNOME shell dashboard and MacOS Mission Control
+like interface for Xfce desktop.  It can be configured to run with any
+keyboard shortcut, when executed it provides an overview of applications
+currently opened which let user to switch between different applications.  Its
+search feature works like Xfce's app finder and makes it convenient to search
+for and start applications. ")
+    (license gpl2)))
+
 (define-public mate-polkit-for-xfce
   (package/inherit mate-polkit
     (arguments