diff mbox series

[bug#54570] gnu: Add parole.

Message ID 20220325230522.6352-1-tumashu@163.com
State Accepted
Headers show
Series [bug#54570] gnu: Add parole. | expand

Commit Message

Feng Shu March 25, 2022, 11:05 p.m. UTC
From: Feng Shu <tumashu@163.com>

* gnu/packages/xfce.scm (parole): New variable.
---
 gnu/packages/xfce.scm | 44 +++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 44 insertions(+)

Comments

M March 26, 2022, 12:31 p.m. UTC | #1
tumashu@163.com schreef op za 26-03-2022 om 07:05 [+0800]:
> +                             #$gst-plugins-base

This hardcoding prevents package transformations.
Try #$(this-package-input "gst-plugins-base") instead.

Greetings,
Maxime.
diff mbox series

Patch

diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index a2d8e99290..76f904d423 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -904,6 +904,50 @@  (define-public gigolo
 local and remote file systems and manage bookmarks of such.")
     (license gpl2)))                              ;version 2 only
 
+(define-public parole
+  (package
+    (name "parole")
+    (version "4.16.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://archive.xfce.org/src/apps/"
+                                  name "/" (version-major+minor version) "/"
+                                  name "-" version ".tar.bz2"))
+              (sha256
+               (base32
+                "1rx7apylqb7mf1dl0sswj1630fca3ddk4x1gcdmlv5ykrkc5lc0d"))))
+    (build-system gnu-build-system)
+    (arguments
+     (list
+      #:configure-flags
+      #~(list (string-append "CPPFLAGS=-I"
+                             #$gst-plugins-base
+                             "/include/gstreamer-1.0"))
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'install 'wrap-parole
+            (lambda _
+              (let ((gst-plugin-path (getenv "GST_PLUGIN_SYSTEM_PATH")))
+                (wrap-program (string-append #$output "/bin/parole")
+                  `("GST_PLUGIN_SYSTEM_PATH" ":" prefix (,gst-plugin-path)))))))))
+    (native-inputs
+     (list pkg-config intltool gobject-introspection))
+    (inputs
+     (list dbus-glib
+           (list glib "bin")
+           gstreamer
+           gst-plugins-base
+           gst-plugins-good
+           libnotify
+           libxfce4ui
+           libxfce4util))
+    (home-page "https://www.xfce.org/")
+    (synopsis "Modern simple media player based on the GStreamer framework")
+    (description "Parole is a modern simple media player based on the
+GStreamer framework and written to fit well in the Xfce desktop.  Parole
+features playback of local media files, DVD/CD and live streams. ")
+    (license gpl2)))                    ;version 2 only
+
 (define-public xfce4-terminal
   (package
     (name "xfce4-terminal")