diff mbox series

[bug#54507,v3,3/3] gnu: openfst-1.7.3: Enable ngram-fst extension & C++14 build

Message ID 20220324195933.2129-4-rind38@disroot.org
State Accepted
Headers show
Series Add openfst 1.7.3 with extensions for kaldi | expand

Commit Message

Aurora March 24, 2022, 7:59 p.m. UTC
The extension doesn't build in old versions of openfst such as 1.7.3 without
manually setting CXXFLAGS.

This package definition, including this workaround to build extensions
successfully, will need to be removed once kaldi is fixed upstream and can be
used with up-to-date versions of openfst.
---
 gnu/packages/machine-learning.scm | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

Comments

Aurora March 24, 2022, 8:01 p.m. UTC | #1
I just finished building this again, just to make sure.

I also added that cover letter to summarize just what the changes and
rationales behind them were.
Aurora April 3, 2022, 11:12 p.m. UTC | #2
Aurora <rind38@disroot.org> writes:

> I just finished building this again, just to make sure.
>
> I also added that cover letter to summarize just what the changes and
> rationales behind them were.

Bumping for issue activity. It build successfully.
Aurora April 4, 2022, 12:56 a.m. UTC | #3
Aurora <rind38@disroot.org> writes:

> Aurora <rind38@disroot.org> writes:
>
>> I just finished building this again, just to make sure.
>>
>> I also added that cover letter to summarize just what the changes and
>> rationales behind them were.
>
> Bumping for issue activity. It build successfully.

Review by a friendly #guix user pointed out the commit messages,
revision number and inline explanations need some work.
diff mbox series

Patch

diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index ddc1392..d4a3604 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -596,7 +596,9 @@  optimizing, and searching weighted finite-state transducers (FSTs).")
                                   "FstDownload/openfst-" version ".tar.gz"))
               (sha256
                (base32
-                "038a60w7y8qnbxmcrsim9rafz9mihsny8xv50jpzlr7rl166pp5q"))))))
+                "038a60w7y8qnbxmcrsim9rafz9mihsny8xv50jpzlr7rl166pp5q"))))
+    (arguments '(#:configure-flags '("--enable-ngram-fsts" "CXXFLAGS=-std=c++14")
+                 #:make-flags '("CXXFLAGS=-std=c++14")))))
 
 (define-public shogun
   (package