@@ -4502,44 +4502,6 @@ SMBus access.")
#~(list (string-append "prefix=" #$output)
(string-append "CC=" #$(cc-for-target))))))))
-(define-public xsensors
- (package
- (name "xsensors")
- (version "0.70")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "http://www.linuxhardware.org/xsensors/xsensors-"
- version ".tar.gz"))
- (sha256
- (base32
- "1siplsfgvcxamyqf44h71jx6jdfmvhfm7mh0y1q8ps4zs6pj2zwh"))))
- (build-system gnu-build-system)
- (inputs `(("lm-sensors" ,lm-sensors "lib")
- ("gtk" ,gtk+-2)))
- (native-inputs (list pkg-config))
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'configure 'enable-deprecated
- (lambda _
- (substitute* "src/Makefile.in"
- (("-DGDK_DISABLE_DEPRECATED") "")
- (("-DGTK_DISABLE_DEPRECATED") ""))
- #t))
- (add-before 'configure 'remove-Werror
- (lambda _
- (substitute* '("configure" "src/Makefile.in")
- (("-Werror") ""))
- #t)))))
- (home-page "http://www.linuxhardware.org/xsensors/")
- (synopsis "Hardware health information viewer")
- (description
- "Xsensors reads data from the libsensors library regarding hardware
-health such as temperature, voltage and fan speed and displays the information
-in a digital read-out.")
- (license license:gpl2+)))
-
(define-public perf
(package
(name "perf")
@@ -10,6 +10,7 @@
;;; Copyright © 2016 Nikita <nikita@n0.is>
;;; Copyright © 2016 Alex Kost <alezost@gmail.com>
;;; Copyright © 2016 David Craven <david@craven.ch>
+;;; Copyright © 2017 Dave Love <fx@gnu.org>
;;; Copyright © 2016, 2017 John Darrington <jmd@gnu.org>
;;; Copyright © 2017, 2018, 2019, 2020, 2021 Marius Bakke <marius@gnu.org>
;;; Copyright © 2017, 2018, 2019 Rutger Helling <rhelling@mykolab.com>
@@ -6131,6 +6132,46 @@ on a button to dismiss it or can select one of several buttons
to answer a question. Xmessage can also exit after a specified time.")
(license license:x11)))
+;; Don't put this in (gnu packages linux) because that would create a
+;; cycle between (gnu packages linux) and (gnu packages gtk).
+(define-public xsensors
+ (package
+ (name "xsensors")
+ (version "0.70")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://www.linuxhardware.org/xsensors/xsensors-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1siplsfgvcxamyqf44h71jx6jdfmvhfm7mh0y1q8ps4zs6pj2zwh"))))
+ (build-system gnu-build-system)
+ (inputs `(("lm-sensors" ,lm-sensors "lib")
+ ("gtk" ,gtk+-2)))
+ (native-inputs (list pkg-config))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'enable-deprecated
+ (lambda _
+ (substitute* "src/Makefile.in"
+ (("-DGDK_DISABLE_DEPRECATED") "")
+ (("-DGTK_DISABLE_DEPRECATED") ""))
+ #t))
+ (add-before 'configure 'remove-Werror
+ (lambda _
+ (substitute* '("configure" "src/Makefile.in")
+ (("-Werror") ""))
+ #t)))))
+ (home-page "http://www.linuxhardware.org/xsensors/")
+ (synopsis "Hardware health information viewer")
+ (description
+ "Xsensors reads data from the libsensors library regarding hardware
+health such as temperature, voltage and fan speed and displays the information
+in a digital read-out.")
+ (license license:gpl2+)))
+
(define-public xterm
(package
(name "xterm")