diff mbox series

[bug#54506,v2] gnu: openfst: Update to 1.8.2, enable ngram extension

Message ID 20220323154359.2684-1-rind38@disroot.org
State Accepted
Headers show
Series [bug#54506,v2] gnu: openfst: Update to 1.8.2, enable ngram extension | expand

Commit Message

Aurora March 23, 2022, 3:43 p.m. UTC
This extension is required by some programs that depend on openfst that aren't
yet packaged.

The extension itself also depends on C++14 to build due to make_unique.
---
 gnu/packages/machine-learning.scm | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)

Comments

Ludovic Courtès May 15, 2022, 8:29 p.m. UTC | #1
Hi,

Aurora <rind38@disroot.org> skribis:

> openfst 1.8.2 already moved to C++17
>
> Aurora (1):
>   gnu: openfst: Update to 1.8.2, enable ngram extension
>
>  gnu/packages/machine-learning.scm | 5 +++--
>  1 file changed, 3 insertions(+), 2 deletions(-)

Applied to the ‘staging’ branch, thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index afac56f..b13e800 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -570,15 +570,16 @@  sample proximities between pairs of cases.")
 (define-public openfst
   (package
     (name "openfst")
-    (version "1.7.9")
+    (version "1.8.2")
     (source (origin
               (method url-fetch)
               (uri (string-append "http://www.openfst.org/twiki/pub/FST/"
                                   "FstDownload/openfst-" version ".tar.gz"))
               (sha256
                (base32
-                "1pmx1yhn2gknj0an0zwqmzgwjaycapi896244np50a8y3nrsw6ck"))))
+                "0hlbdmjjf1jgsvi3d2hwni5lz3l9a5bzj6ijpbawa8a7cbrpp66y"))))
     (build-system gnu-build-system)
+    (arguments '(#:configure-flags '("--enable-ngram-fsts" "CXXFLAGS=-std=c++14")))
     (home-page "http://www.openfst.org")
     (synopsis "Library for weighted finite-state transducers")
     (description "OpenFst is a library for constructing, combining,