diff mbox series

[bug#54527] gnu: Add gigolo.

Message ID 20220322205229.10070-1-tumashu@163.com
State Accepted
Headers show
Series [bug#54527] gnu: Add gigolo. | expand

Commit Message

Feng Shu March 22, 2022, 8:52 p.m. UTC
From: Feng Shu <tumashu@163.com>

* gnu/packages/xfce.scm (gigolo): New variable.
---
 gnu/packages/xfce.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index cdd98f2863..b58a517257 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -881,6 +881,29 @@  (define-public xfdesktop
 devices and folders.")
     (license gpl2+)))
 
+(define-public gigolo
+  (package
+    (name "gigolo")
+    (version "0.5.2")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://archive.xfce.org/src/apps/"
+                                  name "/" (version-major+minor version)
+                                  "/" name "-" version ".tar.bz2"))
+              (sha256
+               (base32
+                "1hxv3lla567nnqxxly8xfi8fzmpcdhxb493x9hinr7szfnh1ljp3"))))
+    (build-system gnu-build-system)
+    (native-inputs (list pkg-config intltool))
+    (inputs (list gtk+))
+    (home-page "https://www.xfce.org/")
+    (synopsis "A frontend to easily manage connections to remote filesystems")
+    (description
+     "A frontend to easily manage connections to remote filesystems using
+GIO/GVfs.  It allows you to quickly connect/mount local and remote filesystems
+and manage bookmarks of such.")
+    (license gpl2+)))
+
 (define-public xfce4-terminal
   (package
     (name "xfce4-terminal")