diff mbox series

[bug#54515,v3] gnu: streamlink: Update to 3.2.0.

Message ID 20220322171151.7337-1-chadwainholness@gmail.com
State Accepted
Headers show
Series [bug#54515,v3] gnu: streamlink: Update to 3.2.0. | expand

Commit Message

Chadwain Holness March 22, 2022, 5:11 p.m. UTC
* gnu/packages/video.scm (streamlink): Update to 3.2.0.
[inputs]: Add python-lxml and python-pycountry, remove python-iso3166 and python-iso639.
[arguments]<#:phases>{check}: Use pytest.
* gnu.packages/xml.scm (python-lxml): Update to 4.7.1.
(python-pycountry): Update to 22.3.5.


Sorry thought I included this change before

---
 gnu/packages/python-xyz.scm |  4 ++--
 gnu/packages/video.scm      | 19 +++++++++++++------
 gnu/packages/xml.scm        |  4 ++--
 3 files changed, 17 insertions(+), 10 deletions(-)

Comments

Ludovic Courtès March 24, 2022, 11:49 a.m. UTC | #1
Hi,

Chadwain Holness <chadwainholness@gmail.com> skribis:

> * gnu/packages/video.scm (streamlink): Update to 3.2.0.
> [inputs]: Add python-lxml and python-pycountry, remove python-iso3166 and python-iso639.
> [arguments]<#:phases>{check}: Use pytest.
> * gnu.packages/xml.scm (python-lxml): Update to 4.7.1.
> (python-pycountry): Update to 22.3.5.

(This last one is actually in python-xyz.scm.)

One last request: We normally include one change per patch:

  https://guix.gnu.org/manual/devel/en/html_node/Submitting-Patches.html

Thus, unless all three packages need to be updated in lockstep, could
you submit them as one patch per package update?

After that I promise we’re done.  :-)

Thanks in advance!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 7649dd0ad5..dd18fbc65c 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -18414,14 +18414,14 @@  (define-public python-ddt
 (define-public python-pycountry
   (package
     (name "python-pycountry")
-    (version "18.5.26")
+    (version "22.3.5")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "pycountry" version))
        (sha256
         (base32
-         "15q9j047s3yc9cfcxq1ch8b71f81na44cr6dydd5gxk0ki9a4akz"))))
+         "0ihnkh86zz01vi46gcwgq6h71jrpj7hq71zi13c98n2qdhj3l5mj"))))
     (build-system python-build-system)
     (home-page "https://bitbucket.org/flyingcircus/pycountry")
     (synopsis "ISO databases for languages, countries, currencies, etc.")
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index dc05c0a222..dab1d9c907 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -60,6 +60,7 @@ 
 ;;; Copyright © 2022 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
 ;;; Copyright © 2022 Bird <birdsite@airmail.cc>
 ;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
+;;; Copyright © 2022 Chadwain Holness <chadwainholness@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -3135,28 +3136,34 @@  (define-public xvid
 (define-public streamlink
   (package
     (name "streamlink")
-    (version "2.0.0")
+    (version "3.2.0")
     (source
       (origin
         (method url-fetch)
         (uri (pypi-uri "streamlink" version))
         (sha256
          (base32
-          "1nv2kj1k42a1b20ws8sdzlxk3wh1qz6pg5mxp75433b3c7lxksn0"))))
+          "09nrspga15svzi0hmakcarbciav0nzf30hg1ff53gia473cd4w4p"))))
     (build-system python-build-system)
-    (home-page "https://github.com/streamlink/streamlink")
+    (arguments
+     `(#:phases (modify-phases %standard-phases
+         (replace 'check
+          (lambda* (#:key tests? #:allow-other-keys)
+              (when tests?
+                  (invoke "python" "-m" "pytest")))))))
     (native-inputs
-     (list python-freezegun python-pytest python-mock
+     (list python-freezegun python-mock python-pytest
            python-requests-mock))
     (propagated-inputs
      (list python-pysocks
            python-websocket-client
-           python-iso3166
-           python-iso639
            python-isodate
+           python-lxml
+           python-pycountry
            python-pycryptodome
            python-requests
            python-urllib3))
+    (home-page "https://github.com/streamlink/streamlink")
     (synopsis "Extract streams from various services")
     (description "Streamlink is command-line utility that extracts streams
 from sites like Twitch.tv and pipes them into a video player of choice.")
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 49275c3e0c..50f552e048 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -2500,13 +2500,13 @@  (define-public python-elementpath
 (define-public python-lxml
   (package
     (name "python-lxml")
-    (version "4.6.3")
+    (version "4.7.1")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "lxml" version))
        (sha256
-        (base32 "0s14r1w2x9sdlcsw8mxiqgw4rz5zs5lpqpxrfyn4a1mkndqqbdrr"))
+        (base32 "090viyanaki4q7w7i000xl0qh4in52bkl3qal55sz2bbm8w3hqd1"))
        ;; Adapt a test to libxml2 2.9.12, taken from this commit:
        ;; https://github.com/lxml/lxml/commit/852ed1092bd80b6b9a51db24371047e
        (modules '((guix build utils)))