diff mbox series

[bug#54503] gnu: sbcl-ningle: Update to 2e85675.

Message ID 20220321163542.32583-1-jgart@dismail.de
State Accepted
Headers show
Series [bug#54503] gnu: sbcl-ningle: Update to 2e85675. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

jgart March 21, 2022, 4:35 p.m. UTC
* gnu/packages/lisp-xyz.scm (sbcl-ningle): Update to 2e85675.
[arguments]: Remove custom phase that changes the name of compiled files
causing a permission denied error when loading ningle.
See this discussion:
https://lists.gnu.org/archive/html/help-guix/2021-12/msg00067.html

Co-authored-by: Guillaume Le Vaillant <glv@posteo.net>

Hi Guillaume,

Here is an upgrade to ningle that also fixes what we were discussing at 
https://lists.gnu.org/archive/html/help-guix/2021-12/msg00067.html

I added you as co-author. Thank you!

all best,

jgart

---
 gnu/packages/lisp-xyz.scm | 32 ++++----------------------------
 1 file changed, 4 insertions(+), 28 deletions(-)

Comments

M March 21, 2022, 6:40 p.m. UTC | #1
jgart via Guix-patches via schreef op ma 21-03-2022 om 12:35 [-0400]:
> -       ;; TODO: pull in clack-test

Why is this comment removed?  Tests are still disabled.

Greetings,
Maxime.
diff mbox series

Patch

diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 85f8af31bb..cbb8e1b851 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -4826,8 +4826,8 @@  (define-public ecl-trivial-mimes
   (sbcl-package->ecl-package sbcl-trivial-mimes))
 
 (define-public sbcl-ningle
-  (let ((commit "50bd4f09b5a03a7249bd4d78265d6451563b25ad")
-        (revision "1"))
+  (let ((commit "2e85675bbb668d6ef341514fc9f22391a0f506b1")
+        (revision "2"))
     (package
       (name "sbcl-ningle")
       (version (git-version "0.3.0" revision commit))
@@ -4839,34 +4839,10 @@  (define-public sbcl-ningle
                (commit commit)))
          (file-name (git-file-name name version))
          (sha256
-          (base32 "1bsl8cnxhacb8p92z9n89vhk1ikmij5zavk0m2zvmj7iqm79jzgw"))))
+          (base32 "0s9nn8ml1j4839rycvdjcbsynkqnhxw1zmrgpjz48smscwdf1f8p"))))
       (build-system asdf-build-system/sbcl)
       (arguments
-       ;; TODO: pull in clack-test
-       '(#:tests? #f
-         #:phases
-         (modify-phases %standard-phases
-           (delete 'cleanup-files)
-           (delete 'cleanup)
-           (add-before 'cleanup 'combine-fasls
-             (lambda* (#:key outputs #:allow-other-keys)
-               (let* ((out (assoc-ref outputs "out"))
-                      (lib (string-append out "/lib/sbcl"))
-                      (ningle-path (string-append lib "/ningle"))
-                      (fasl-files (find-files out "\\.fasl$")))
-                 (mkdir-p ningle-path)
-                 (let ((fasl-path (lambda (name)
-                                    (string-append ningle-path
-                                                   "/"
-                                                   (basename name)
-                                                   "--system.fasl"))))
-                   (for-each (lambda (file)
-                               (rename-file file
-                                            (fasl-path
-                                             (basename file ".fasl"))))
-                             fasl-files))
-                 fasl-files)
-               #t)))))
+       '(#:tests? #f))
       (native-inputs
        (list sbcl-prove))
       (inputs