diff mbox series

[bug#54434,v2,4/7] gnu: mate-polkit-for-xfce: Unhide package.

Message ID 20220318073844.14290-5-mail@brendan.scot
State New
Headers show
Series XFCE Updates | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Brendan Tildesley March 18, 2022, 7:38 a.m. UTC
From: Brendan Tildesley <mail@brendan.scot>

* gnu/packages/xfce.scm (mate-polkit-for-xfce): Package doesn't
particularly need to be hidden.
[name]: Provide a unique name for this variant.
[description]: Explain packages purpose.
---
 gnu/packages/xfce.scm | 11 ++++++++++-
 1 file changed, 10 insertions(+), 1 deletion(-)

Comments

Brendan Tildesley April 4, 2022, 1:13 a.m. UTC | #1
On 3/4/22 8:25 pm, Ludovic Courtès wrote:
> [...]
> “Polkit” is really called “Polkit”; “PolicyKit” was its predecessor and
> it’s important to distinguish them.
Understood.
> I’m not convinced this package needs to be made public though because
> it’s not meant to be installed manually.
>
> WDYT?
I felt packages should have a justification for being hidden rather than 
unhidden :)
If it should be hidden then mate-polkit its' self may as well be..? But 
you can
have it which ever way you want.
What bad thing happens when it isn't hidden? Making work for translators?
>
> Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index 150d21226b..731bbd791d 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -75,6 +75,7 @@  (define-module (gnu packages xfce)
   #:use-module (guix download)
   #:use-module (guix git-download)
   #:use-module (guix gexp)
+  #:use-module (guix i18n)
   #:use-module ((guix licenses) #:hide (freetype))
   #:use-module (guix packages)
   #:use-module (guix utils))
@@ -911,6 +912,7 @@  (define-public xfce4-terminal
 
 (define-public mate-polkit-for-xfce
   (package/inherit mate-polkit
+    (name "mate-polkit-for-xfce")
     (arguments
      `(#:phases
        (modify-phases %standard-phases
@@ -924,7 +926,14 @@  (define-public mate-polkit-for-xfce
                (substitute* old (("MATE;") "XFCE;"))
                ;; To avoid a conflict if both MATE and XFCE are installed.
                (rename-file old new)))))))
-    (properties `((hidden? . #t)))))
+    (synopsis "PolicyKit Authentication agent for XFCE")
+    (description
+     (string-append
+      (package-description mate-polkit) "\n\n"
+      (P_ "This package variant provides the MATE PolicyKit authentication
+agent configured to autostart for XFCE.  This is because the XFCE project does
+not have its own official authentication agent, so we pick MATE PolicyKit as a
+reasonable fit.")))))
 
 (define-public xfce
   (package