@@ -75,6 +75,7 @@ (define-module (gnu packages xfce)
#:use-module (guix download)
#:use-module (guix git-download)
#:use-module (guix gexp)
+ #:use-module (guix i18n)
#:use-module ((guix licenses) #:hide (freetype))
#:use-module (guix packages)
#:use-module (guix utils))
@@ -911,6 +912,7 @@ (define-public xfce4-terminal
(define-public mate-polkit-for-xfce
(package/inherit mate-polkit
+ (name "mate-polkit-for-xfce")
(arguments
`(#:phases
(modify-phases %standard-phases
@@ -924,7 +926,14 @@ (define-public mate-polkit-for-xfce
(substitute* old (("MATE;") "XFCE;"))
;; To avoid a conflict if both MATE and XFCE are installed.
(rename-file old new)))))))
- (properties `((hidden? . #t)))))
+ (synopsis "PolicyKit Authentication agent for XFCE")
+ (description
+ (string-append
+ (package-description mate-polkit) "\n\n"
+ (P_ "This package variant provides the MATE PolicyKit authentication
+agent configured to autostart for XFCE. This is because the XFCE project does
+not have its own official authentication agent, so we pick MATE PolicyKit as a
+reasonable fit.")))))
(define-public xfce
(package
From: Brendan Tildesley <mail@brendan.scot> * gnu/packages/xfce.scm (mate-polkit-for-xfce): Package doesn't particularly need to be hidden. [name]: Provide a unique name for this variant. [description]: Explain packages purpose. --- gnu/packages/xfce.scm | 11 ++++++++++- 1 file changed, 10 insertions(+), 1 deletion(-)