diff mbox series

[bug#54284,v2] gnu: Add python-pytest-pudb.

Message ID 20220315214147.17096-1-jgart@dismail.de
State Accepted
Headers show
Series [bug#54284,v2] gnu: Add python-pytest-pudb. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

jgart March 15, 2022, 9:41 p.m. UTC
* gnu/packages/check.scm (python-pytest-pudb): New variable.

Hi, here is a version 2 of the patch that puts it in the check module instead.

all best,

jgart

---
 gnu/packages/check.scm | 35 +++++++++++++++++++++++++++++++++++
 1 file changed, 35 insertions(+)

Comments

Ludovic Courtès March 18, 2022, 10:16 p.m. UTC | #1
Hi,

jgart <jgart@dismail.de> skribis:

> * gnu/packages/check.scm (python-pytest-pudb): New variable.

[...]

> +(define-public python-pytest-pudb
> +  ;; PyPi does not include tests
> +  (let ((commit "a6b3d2f4d35e558d72bccff472ecde9c9d9c69e5")
> +        (revision "0"))
> +    (package
> +      (name "python-pytest-pudb")
> +      (version "0.7.0")

Could you clarify in a comment how this commit relates to this version
number?  You can remove the ‘revision’ variable, since it’s unused.

> +         (file-name (string-append name "-" commit))

Rather: (file-name (git-file-name name version)).

> +      (synopsis "Pytest PuDB debugger integration")
> +      (description
> +  "@code{python-pytest-pudb} provides PuDB debugger integration based on
> +  pytest PDB integration.")
    ^
Extra space here.

IWBN if you could add a sentence or two explaining what that means.  :-)

Last, please pass it through ‘guix style’.

Could you send an updated patch?

TIA!

Ludo’.
M March 20, 2022, 8:16 a.m. UTC | #2
jgart via Guix-patches via schreef op di 15-03-2022 om 17:41 [-0400]:
> +  (let ((commit "a6b3d2f4d35e558d72bccff472ecde9c9d9c69e5")

This commit is only used in a single place, so don't see any need
to put it in a variable.

Greetings,
Maxime.
diff mbox series

Patch

diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index c66ec4722f..970a8196b5 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -3082,6 +3082,41 @@  (define-public python-pytest-dependency
 skipped if any of the dependencies did fail or has been skipped.")
     (license license:asl2.0)))
 
+(define-public python-pytest-pudb
+  ;; PyPi does not include tests
+  (let ((commit "a6b3d2f4d35e558d72bccff472ecde9c9d9c69e5")
+        (revision "0"))
+    (package
+      (name "python-pytest-pudb")
+      (version "0.7.0")
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+                (url "https://github.com/wronglink/pytest-pudb")
+                (commit commit)))
+         (file-name (string-append name "-" commit))
+         (sha256
+          (base32 "1c0pypxx3y8w7s5bz9iy3w3aablnhn81rnhmb0is8hf2qpm6k3w0"))))
+      (build-system python-build-system)
+      (propagated-inputs (list pudb))
+      (native-inputs
+        (list python-pytest))
+      (arguments
+        `(#:phases
+          (modify-phases %standard-phases
+            (replace 'check
+              (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+                (when tests?
+                  (add-installed-pythonpath inputs outputs)
+                  (invoke "pytest" "-v")))))))
+      (home-page "https://github.com/wronglink/pytest-pudb")
+      (synopsis "Pytest PuDB debugger integration")
+      (description
+  "@code{python-pytest-pudb} provides PuDB debugger integration based on
+  pytest PDB integration.")
+      (license license:expat))))
+
 (define-public python-pytest-datadir
   (package
     (name "python-pytest-datadir")