diff mbox series

[bug#54379,1/2] gnu: linux: update PipeWire & WirePlumber

Message ID 20220314230647.11344-1-kevinboulain@gmail.com
State New
Headers show
Series [bug#54379,1/2] gnu: linux: update PipeWire & WirePlumber | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Kevin Boulain March 14, 2022, 11:06 p.m. UTC
* gnu/packages/linux.scm (pipewire-0.3): Update to 0.3.48.
Also add a few more inputs to PipeWire to enable a few options:
 - libfdk to support the AAC Bluetooth codec
 - libsndfile to build pw-cat
 - libusb for Bluetooth quirks
 - lilv for LV2 plugins
 - readline to build pw-cli
 - webrtc-audio-processing for echo cancellation
* gnu/packages/linux.scm (wireplumber): Update to 0.4.8.

---

PipeWire also supports the aptX Bluetooth codec but the situation
appears to be very muddy: some distributions like Debian, Gentoo or
Arch package libfreeaptx (a fork of libopenaptx to work around licensing
issues) but other like Fedora or OpenSUSE refuse to do it.
---
 gnu/packages/linux.scm | 16 +++++++++++-----
 1 file changed, 11 insertions(+), 5 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index d7ebf54c18..c09276b319 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -8280,7 +8280,7 @@  (define-public pipewire-0.3
   (package
     (inherit pipewire)
     (name "pipewire")
-    (version "0.3.43")
+    (version "0.3.48")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -8289,7 +8289,7 @@  (define-public pipewire-0.3
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "0gp2h0sidapcqmnifl0iipdmbzb18bdh8zdi7pfywr9gsksh0cxy"))))
+                "0abi8z7rfzspsiydc5j5l0x3dqizs5hf726xq30n32jqkwq3y2gs"))))
     (arguments
      '(#:configure-flags
        (list (string-append "-Dudevrulesdir=" (assoc-ref %outputs "out")
@@ -8305,14 +8305,20 @@  (define-public pipewire-0.3
                        bluez
                        jack-2
                        ldacbt
+                       libfdk
+                       libsndfile
+                       libusb
+                       lilv
                        pulseaudio
+                       readline
                        vulkan-loader
-                       vulkan-headers)))))
+                       vulkan-headers
+                       webrtc-audio-processing)))))
 
 (define-public wireplumber
   (package
     (name "wireplumber")
-    (version "0.4.6")
+    (version "0.4.8")
     (source
      (origin
        (method git-fetch)
@@ -8322,7 +8328,7 @@  (define-public wireplumber
              (commit version)))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "0g7xkgkjlxrhs49hqkwrjk2hb478gq55wwydafvvbsv78vsa7qfb"))))
+        (base32 "1xhbymfml6k6l1iqgfbibgbai3j2mb9fkiyvcmk1w7nap21f01y7"))))
     (build-system meson-build-system)
     (arguments
      `(#:configure-flags '("-Dsystemd=disabled"