diff mbox series

[bug#53019,3/9] gnu: Add python-coverage-5.5

Message ID 20220314223614.17668-3-goodoldpaul@autistici.org
State New
Headers show
Series [bug#53019,1/9] gnu: Add python-codeclimate-test-reporter. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Giacomo Leidi March 14, 2022, 10:36 p.m. UTC
* gnu/packages/check.scm (python-coverage-5.5): New variable.
---
 gnu/packages/check.scm | 13 +++++++++++++
 1 file changed, 13 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index c66ec4722f..450ada0cf2 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -38,6 +38,7 @@ 
 ;;; Copyright © 2020, 2021, 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;; Copyright © 2021 Hugo Lecomte <hugo.lecomte@inria.fr>
 ;;; Copyright © 2022 Maxime Devos <maximedevos@telenet.be>
+;;; Copyright © 2022 Giacomo Leidi <goodoldpaul@autistici.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1825,6 +1826,18 @@  (define-public python-coverage
 executed.")
     (license license:bsd-3)))
 
+(define-public python-coverage-5.5
+  (package
+    (inherit python-coverage)
+    (version "5.5")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "coverage" version))
+       (sha256
+        (base32
+         "0b112ly7vvplvm9l411aqknxhr7fzfyp28xhflhkcx78l3lqzrzb"))))))
+
 (define-public python2-coverage
   (package-with-python2 python-coverage))