diff mbox series

[bug#54357,4/4] gnu: Add kak-sudo-write

Message ID 20220314215640.22822-4-paren@disroot.org
State Accepted
Headers show
Series [bug#54357,1/4] gnu: kakoune: Clean up, and add a search path that makes it possible to package kak plugins in guix. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

\( March 14, 2022, 9:56 p.m. UTC
* gnu/packages/text-editors.scm (kak-sudo-write): New variable.
---
 gnu/packages/text-editors.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
index 08cd1a16d9..4b06b8c9bd 100644
--- a/gnu/packages/text-editors.scm
+++ b/gnu/packages/text-editors.scm
@@ -278,6 +278,31 @@  (define-public kak-auto-pairs
      (description "This package provides automatic pair completion for the Kakoune text editor.")
      (license license:unlicense))))
 
+(define-public kak-sudo-write
+  (let ((commit "ec0d6d26ceaadd93d6824630ba587b31e442214d")
+        (revision "0"))
+    (package
+     (name "kak-sudo-write")
+     (version (git-version "0.0.0" revision commit))
+     (source
+      (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/occivink/kakoune-sudo-write")
+             (commit commit)))
+       (sha256
+        (base32 "1c1wajm3c2aa0lda36y2yj2fvf4fbdqjl5ishh9p8qkjxbrb1v1v"))))
+     (build-system copy-build-system)
+     (arguments
+      `(#:install-plan
+        '(("sudo-write.kak" "share/kak/autoload/sudo-write.kak"))))
+     (propagated-inputs (list kakoune))
+     (home-page "https://github.com/occivink/kakoune-sudo-write")
+     (synopsis "Kakoune plugin to save files that you do not have write permissions for.")
+     (description "This package provides a Kakoune plugin that uses sudo to allow saving files that you
+do not have permission to write.")
+     (license license:unlicense))))
+
 (define-public parinfer-rust
   (package
     (name "parinfer-rust")