diff mbox series

[bug#54362,v2] gnu: cl-find-port: Update to 242cfc6.

Message ID 20220313173316.5331-1-jgart@dismail.de
State Accepted
Headers show
Series [bug#54362,v2] gnu: cl-find-port: Update to 242cfc6. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

jgart March 13, 2022, 5:33 p.m. UTC
* gnu/packages/lisp-xyz.scm (cl-find-port): Update to 242cfc6.
[version]: Use git-version function with version stated in asd file.
---
Hi all,

Thanks for the review. It is much appreciated.

Here is a v2 of the requested changes.

Guillaume, thanks for pointing out the version number in the asd file.

That version number is from 7 years ago according to `git blame` but if
you think we should still use it that is fine with me. I think the author
is probably just not making version releases and just releasing commits.

all best,

jgart

 gnu/packages/lisp-xyz.scm | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index fc18742e3c..b95466d93b 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -5120,12 +5120,12 @@  (define-public cl-verbose
   (sbcl-package->cl-source-package sbcl-verbose))
 
 (define-public sbcl-find-port
-  (let ((commit "00c96a25af93a0f8681d34ec548861f2d7485478")
-        (revision "1"))
+  (let ((commit "811727f88d7f000623bf92fdb0e64678a7112a28")
+        (revision "2"))
     (package
       (name "sbcl-find-port")
       (build-system asdf-build-system/sbcl)
-      (version "0.1")
+      (version (git-version "0.1" revision commit))
       (home-page "https://github.com/eudoxia0/find-port")
       (source
        (origin
@@ -5136,7 +5136,7 @@  (define-public sbcl-find-port
          (file-name (git-file-name name version))
          (sha256
           (base32
-           "0d6dzbb45jh0rx90wgs6v020k2xa87mvzas3mvfzvivjvqqlpryq"))))
+           "1fw6q7d2bxxb7fqk548ylq8mx4sz95yc0q5h0rwd0mnqjrbwbari"))))
       (native-inputs
        (list sbcl-fiveam))
       (inputs