diff mbox series

[bug#54273,V3] gnu : nicotine+: Update to 3.2.1.

Message ID 20220313154124.18317-1-fatimatoothpaste@disroot.org
State Accepted
Headers show
Series [bug#54273,V3] gnu : nicotine+: Update to 3.2.1. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Fatima Toothpaste March 13, 2022, 3:41 p.m. UTC
* gnu/packages/nicotine.scm (nicotine+): Update to 3.2.1.
  [source]: Delete network requried tests in snippet.
  [arguments]: Remove trailing #t.
  Replae 'check phase to run proper test.
  [inputs]: Add bash-minimal, gspell, libappindicator.
  [native-inputs]: Remove python-pytest. Add xvfb-run.
  [home-page]: Update URL.
---
 gnu/packages/nicotine.scm | 31 ++++++++++++++++++++-----------
 1 file changed, 20 insertions(+), 11 deletions(-)

Comments

Ludovic Courtès March 15, 2022, 9:52 a.m. UTC | #1
Hi,

Fatima Toothpaste <fatimatoothpaste@disroot.org> skribis:

> * gnu/packages/nicotine.scm (nicotine+): Update to 3.2.1.
>   [source]: Delete network requried tests in snippet.
>   [arguments]: Remove trailing #t.
>   Replae 'check phase to run proper test.
>   [inputs]: Add bash-minimal, gspell, libappindicator.
>   [native-inputs]: Remove python-pytest. Add xvfb-run.
>   [home-page]: Update URL.

[...]

> +              (snippet '(begin
> +                          (delete-file-recursively "test/integration")))))

I added a comment above the snippet explaining it and applied.

Thanks,
Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/nicotine.scm b/gnu/packages/nicotine.scm
index 8e194697de..d46c5603f3 100644
--- a/gnu/packages/nicotine.scm
+++ b/gnu/packages/nicotine.scm
@@ -1,5 +1,6 @@ 
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2020 Martin Becze <mjbecze@riseup.net>
+;;; Copyright © 2022 Fatima Toothpaste <fatimatoothpaste@disroot.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -21,23 +22,29 @@  (define-module (gnu packages nicotine)
   #:use-module (guix packages)
   #:use-module (guix git-download)
   #:use-module (guix build-system python)
+  #:use-module (gnu packages bash)
+  #:use-module (gnu packages freedesktop)
   #:use-module (gnu packages glib)
+  #:use-module (gnu packages gnome)
   #:use-module (gnu packages gettext)
   #:use-module (gnu packages gtk)
-  #:use-module (gnu packages check)
-  #:use-module (gnu packages mp3))
+  #:use-module (gnu packages mp3)
+  #:use-module (gnu packages xorg))
 
 (define-public nicotine+
   (package
     (name "nicotine+")
-    (version "2.1.2")
+    (version "3.2.1")
     (source (origin
               (method git-fetch)
               (uri (git-reference
                     (url "https://github.com/Nicotine-Plus/nicotine-plus")
                     (commit version)))
               (file-name (git-file-name name version))
-              (sha256 (base32 "18rra8yqjr10z23chzcp53ncbd5fhm0iqgqxpbxfq7a10za02v6l"))))
+              (sha256 (base32 "1x08z5lvkdl62dkc11vrsackgzsh1vr9vp3vgsgfzjyrvlsybmfw"))
+              (modules '((guix build utils)))
+              (snippet '(begin
+                          (delete-file-recursively "test/integration")))))
     (build-system python-build-system)
     (arguments
      `(#:imported-modules ((guix build glib-or-gtk-build-system)
@@ -55,18 +62,20 @@  (define-public nicotine+
                           "/bin/nicotine"))
                    (gi-typelib-path (getenv "GI_TYPELIB_PATH")))
                (wrap-program prog
-                 `("GI_TYPELIB_PATH" ":" prefix (,gi-typelib-path)))
-               #t)))
+                 `("GI_TYPELIB_PATH" ":" prefix (,gi-typelib-path))))))
          (add-after 'wrap-program 'glib-or-gtk-wrap
            (assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-wrap))
          (add-after 'glib-or-gtk-wrap 'glib-or-gtk-compile-schemas
-           (assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-compile-schemas)))))
+           (assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-compile-schemas))
+         (replace 'check
+           (lambda* (#:key tests? #:allow-other-keys)
+             (when tests?
+               (invoke "xvfb-run" "python" "-m" "unittest")))))))
     (inputs
-     (list gtk+ python-pygobject python-pytaglib))
+     (list bash-minimal gspell gtk+ python-pygobject libappindicator python-pytaglib))
     (native-inputs
-     `(("python-pytest" ,python-pytest)
-       ("gettext" ,gettext-minimal)))
-    (home-page "https://nicotine-plus.github.io/nicotine-plus/")
+     (list gettext-minimal xvfb-run))
+    (home-page "https://nicotine-plus.org/")
     (synopsis "Graphical client for Soulseek")
     (description
      "Nicotine+ is a graphical client for the Soulseek peer-to-peer