diff mbox series

[bug#54334] gnu: python-gitlab: update to 3.2.0

Message ID 20220311001516.7959-1-GNUtoo@cyberdimension.org
State Accepted
Headers show
Series [bug#54334] gnu: python-gitlab: update to 3.2.0 | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Denis 'GNUtoo' Carikli March 11, 2022, 12:15 a.m. UTC
* gnu/packages/python-web.scm (python-gitlab): Update to 3.2.0

Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
---
 gnu/packages/python-web.scm | 27 +++++++++++++--------------
 1 file changed, 13 insertions(+), 14 deletions(-)


base-commit: 5397c18157f12e9127b5a9a59b0aa5a4eb058839

Comments

Ludovic Courtès March 16, 2022, 2:11 p.m. UTC | #1
Hi,

Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org> skribis:

> * gnu/packages/python-web.scm (python-gitlab): Update to 3.2.0
>
> Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>

Applied.

> +    (arguments
> +     `( ;Tests require network access
> +        #:tests? #f))

Nitpick: I turned it into a margin comment, like so:

    (arguments
     `(#:tests? #f))                             ;tests require network access

Use one semicolon for margin comments, two for standalone comments.  See
<https://guix.gnu.org/manual/devel/en/html_node/Formatting-Code.html>.

Thanks,
Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 240c58b665..69dbd87acd 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -48,6 +48,7 @@ 
 ;;; Copyright © 2021 jgart <jgart@dismail.de>
 ;;; Copyright © 2021 Alice Brenon <alice.brenon@ens-lyon.fr>
 ;;; Copyright © 2022 John Kehayias <john.kehayias@protonmail.com>
+;;; Copyright © 2022 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -4910,21 +4911,19 @@  (define-public python-translation-finder
 (define-public python-gitlab
   (package
     (name "python-gitlab")
-    (version "1.15.0")
-    (source
-      (origin
-        (method url-fetch)
-        (uri (pypi-uri "python-gitlab" version))
-        (sha256
-         (base32
-          "0zl6kz8v8cg1bcy2r78b2snb0lpw0b573gdx2x1ps0nhsh75l4j5"))))
+    (version "3.2.0")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "python-gitlab" version))
+              (sha256
+               (base32
+                "1gi4lp2g4k99zqcx2bgqx940bpmpbc1w9qkl5gy33hpy148yhvlg"))))
     (build-system python-build-system)
-    (propagated-inputs
-     (list python-requests python-six))
-    (native-inputs
-     (list python-httmock python-mock))
-    (home-page
-      "https://github.com/python-gitlab/python-gitlab")
+    (arguments
+     `( ;Tests require network access
+        #:tests? #f))
+    (propagated-inputs (list python-requests python-requests-toolbelt))
+    (home-page "https://github.com/python-gitlab/python-gitlab")
     (synopsis "Interact with GitLab API")
     (description "This package provides an extended library for interacting
 with GitLab instances through their API.")