diff mbox series

[bug#53046,v4] gnu: python-args: Patch reference to basestring.

Message ID 20220310172808.23485-1-tanguy@bioneland.org
State Accepted
Headers show
Series [bug#53046,v4] gnu: python-args: Patch reference to basestring. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Tanguy LE CARROUR March 10, 2022, 5:28 p.m. UTC
Hi Maxime,

I **totally** forgot about this one! Seems like no one is using it.
`python2-args` also builds. But no package seems to depend on it anyway.

Regards,

Tanguy


* gnu/packages/python-xyz.scm (python-args)[source]: Use the latest version
from the git repository to get the test suite.
[home-page]: Update URL.
[native-inputs]: Add python-nose.
[arguments]: Replace reference to basestring with str. Invoke nosetests.
---
 gnu/packages/python-xyz.scm | 45 ++++++++++++++++++++++++-------------
 1 file changed, 30 insertions(+), 15 deletions(-)

Comments

Ludovic Courtès Aug. 4, 2022, 9:09 a.m. UTC | #1
Hi Tanguy,

Tanguy Le Carrour <tanguy@bioneland.org> skribis:

> * gnu/packages/python-xyz.scm (python-args)[source]: Use the latest version
> from the git repository to get the test suite.
> [home-page]: Update URL.
> [native-inputs]: Add python-nose.
> [arguments]: Replace reference to basestring with str. Invoke nosetests.

Finally applied, sorry for the delay, and thanks for reminding us!  :-)

Ludo’.
Tanguy LE CARROUR Aug. 4, 2022, 9:42 a.m. UTC | #2
Hi Ludo’,


Quoting Ludovic Courtès (2022-08-04 11:09:39)
> Tanguy Le Carrour <tanguy@bioneland.org> skribis:
> 
> > * gnu/packages/python-xyz.scm (python-args)[source]: Use the latest version
> > from the git repository to get the test suite.
> > [home-page]: Update URL.
> > [native-inputs]: Add python-nose.
> > [arguments]: Replace reference to basestring with str. Invoke nosetests.
> 
> Finally applied, sorry for the delay, and thanks for reminding us!  :-)

Thanks!
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5c003e3c1a..b8798fa671 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -13638,21 +13638,36 @@  (define-public python-icalendar
     (license license:bsd-2)))
 
 (define-public python-args
-  (package
-    (name "python-args")
-    (version "0.1.0")
-    (source (origin
-              (method url-fetch)
-              (uri (pypi-uri "args" version))
-              (sha256
-               (base32
-                "057qzi46h5dmxdqknsbrssn78lmqjlnm624iqdhrnpk26zcbi1d7"))))
-    (build-system python-build-system)
-    (home-page "https://github.com/kennethreitz/args")
-    (synopsis "Command-line argument parser")
-    (description
-     "This library provides a Python module to parse command-line arguments.")
-    (license license:bsd-3)))
+  (let ((commit "9460f1a35eb3055e9e4de1f0a6932e0883c72d65") (revision "0"))
+    (package
+      (name "python-args")
+      (version (git-version "0.1.0" revision commit))
+      (home-page "https://github.com/kennethreitz-archive/args")
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url home-page)
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "1zfxpbp9vldqdrjmd0c6y3wisl35mx5v8zlyp3nhwpy1730wrc9j"))))
+      (build-system python-build-system)
+      (arguments
+       `(#:phases (modify-phases %standard-phases
+                    (add-after 'unpack 'patch-args.py
+                      (lambda _
+                        (substitute* "args.py"
+                          (("basestring") "str"))))
+                    (replace 'check
+                      (lambda* (#:key tests? #:allow-other-keys)
+                        (when tests?
+                          (invoke "nosetests" "-v")))))))
+      (native-inputs (list python-nose))
+      (synopsis "Command-line argument parser")
+      (description
+       "This library provides a Python module to parse command-line arguments.")
+      (license license:bsd-3))))
 
 (define-public python2-args
   (package-with-python2 python-args))