diff mbox series

[bug#54274] : Add gmp to Blender.

Message ID 20220306182649.5f3cfb01@riseup.net
State Accepted
Headers show
Series [bug#54274] : Add gmp to Blender. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Csepp March 6, 2022, 5:26 p.m. UTC
This is required for boolean operators to work. Tested, everything
seems to be working fine.

Comments

Guillaume Le Vaillant March 8, 2022, 1:51 p.m. UTC | #1
Patch pushed as 1217b02f4539e14cc904ada218d52ffb48cd8f76.
Thanks.
diff mbox series

Patch

From f3a5ab5d5ef3ed0cee388f35ebc2da5947d967bd Mon Sep 17 00:00:00 2001
From: raingloom <raingloom@riseup.net>
Date: Sun, 6 Mar 2022 06:31:34 +0100
Subject: [PATCH] gnu: blender: Enable boolean operations on meshes.

* gnu/packages/graphics.scm (blender): Add optional gmp dependency.
[inputs]: Add gmp.
---
 gnu/packages/graphics.scm | 1 +
 1 file changed, 1 insertion(+)

diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index f5152b0ba2..317687c701 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -496,6 +496,7 @@  (define-public blender
        ("libtiff" ,libtiff)
        ("ffmpeg" ,ffmpeg)
        ("fftw" ,fftw)
+       ("gmp" ,gmp) ;; needed for boolean operations on meshes
        ("jack" ,jack-1)
        ("libsndfile" ,libsndfile)
        ("freetype" ,freetype)
-- 
2.34.0