diff mbox series

[bug#54273] gnu: nicotine+: update to 3.2.1.

Message ID 20220306054551.19383-1-fatimatoothpaste@disroot.org
State Accepted
Headers show
Series [bug#54273] gnu: nicotine+: update to 3.2.1. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Fatima Toothpaste March 6, 2022, 5:45 a.m. UTC
* gnu/packages/nicotine.scm (nicotine+): Update to 3.2.1.
  [arguments]: Delete check phase.
  [inputs]: Add bash-minimal.
  [home-page]: Update URL.
---
 gnu/packages/nicotine.scm | 15 ++++++++++-----
 1 file changed, 10 insertions(+), 5 deletions(-)

Comments

Ludovic Courtès March 11, 2022, 10:11 p.m. UTC | #1
Hi,

Fatima Toothpaste <fatimatoothpaste@disroot.org> skribis:

> * gnu/packages/nicotine.scm (nicotine+): Update to 3.2.1.
>   [arguments]: Delete check phase.
>   [inputs]: Add bash-minimal.
>   [home-page]: Update URL.

[...]

> +         ;;Tests require network connection
> +         (delete 'check))))

Tests should rather be disabled with #:tests? #f.

However, could you check if we can just skip (or tweak?) the tests that
specifically depend on networking?

The rest of the patch looks good to me.

Thanks,
Ludo’.
Fatima Toothpaste March 13, 2022, 1:14 a.m. UTC | #2
Sorry, I fixed what you said, and other messes i made.
Thanks for reviewing.

On 3/12/22 07:11, Ludovic Courtès wrote:
> Hi,
>
> Fatima Toothpaste <fatimatoothpaste@disroot.org> skribis:
>
>> * gnu/packages/nicotine.scm (nicotine+): Update to 3.2.1.
>>    [arguments]: Delete check phase.
>>    [inputs]: Add bash-minimal.
>>    [home-page]: Update URL.
> [...]
>
>> +         ;;Tests require network connection
>> +         (delete 'check))))
> Tests should rather be disabled with #:tests? #f.
>
> However, could you check if we can just skip (or tweak?) the tests that
> specifically depend on networking?
>
> The rest of the patch looks good to me.
>
> Thanks,
> Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/nicotine.scm b/gnu/packages/nicotine.scm
index 8e194697de..6890c26cb6 100644
--- a/gnu/packages/nicotine.scm
+++ b/gnu/packages/nicotine.scm
@@ -1,5 +1,6 @@ 
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2020 Martin Becze <mjbecze@riseup.net>
+;;; Copyright © 2022 Fatima Toothpaste <fatimatoothpaste@disroot.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -21,6 +22,7 @@  (define-module (gnu packages nicotine)
   #:use-module (guix packages)
   #:use-module (guix git-download)
   #:use-module (guix build-system python)
+  #:use-module (gnu packages bash)
   #:use-module (gnu packages glib)
   #:use-module (gnu packages gettext)
   #:use-module (gnu packages gtk)
@@ -30,14 +32,14 @@  (define-module (gnu packages nicotine)
 (define-public nicotine+
   (package
     (name "nicotine+")
-    (version "2.1.2")
+    (version "3.2.1")
     (source (origin
               (method git-fetch)
               (uri (git-reference
                     (url "https://github.com/Nicotine-Plus/nicotine-plus")
                     (commit version)))
               (file-name (git-file-name name version))
-              (sha256 (base32 "18rra8yqjr10z23chzcp53ncbd5fhm0iqgqxpbxfq7a10za02v6l"))))
+              (sha256 (base32 "1x08z5lvkdl62dkc11vrsackgzsh1vr9vp3vgsgfzjyrvlsybmfw"))))
     (build-system python-build-system)
     (arguments
      `(#:imported-modules ((guix build glib-or-gtk-build-system)
@@ -60,13 +62,16 @@  (define-public nicotine+
          (add-after 'wrap-program 'glib-or-gtk-wrap
            (assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-wrap))
          (add-after 'glib-or-gtk-wrap 'glib-or-gtk-compile-schemas
-           (assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-compile-schemas)))))
+           (assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-compile-schemas))
+         ;;Tests require network connection
+         (delete 'check))))
     (inputs
-     (list gtk+ python-pygobject python-pytaglib))
+     ;;TODO: Add libayatana-appindicator
+     (list bash-minimal gtk+ python-pygobject python-pytaglib))
     (native-inputs
      `(("python-pytest" ,python-pytest)
        ("gettext" ,gettext-minimal)))
-    (home-page "https://nicotine-plus.github.io/nicotine-plus/")
+    (home-page "https://nicotine-plus.org/nicotine-plus/")
     (synopsis "Graphical client for Soulseek")
     (description
      "Nicotine+ is a graphical client for the Soulseek peer-to-peer