diff mbox series

[bug#53019,2/3] gnu: Add python-ddlparse.

Message ID 20220305231459.22969-2-goodoldpaul@autistici.org
State New
Headers show
Series [bug#53019,1/3] gnu: Add python-codeclimate-test-reporter. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Giacomo Leidi March 5, 2022, 11:14 p.m. UTC
* gnu/packages/python-xyz.scm (python-ddlparse): New variable.
---
 gnu/packages/python-xyz.scm | 38 +++++++++++++++++++++++++++++++++++++
 1 file changed, 38 insertions(+)

Comments

M March 6, 2022, 10:19 a.m. UTC | #1
Giacomo Leidi via Guix-patches via schreef op zo 06-03-2022 om 00:14
[+0100]:
> +             (("codecov>=2\\.1\\.8") "codecov")
> +             (("pytest-cov>=2\\.10\\.0") "pytest-cov"))
M March 6, 2022, 10:19 a.m. UTC | #2
Giacomo Leidi via Guix-patches via schreef op zo 06-03-2022 om 00:14
[+0100]:
> +             (("codecov>=2\\.1\\.8") "codecov")
> +             (("pytest-cov>=2\\.10\\.0") "pytest-cov"))

Instead of ignoring upstream's lower bound on the versions,
how about updating the dependencies in Guix?

Greetings,
Maxime.
Giacomo Leidi March 14, 2022, 10:27 p.m. UTC | #3
Dear Maxime,

On 3/6/22 11:19, Maxime Devos wrote:
> Giacomo Leidi via Guix-patches via schreef op zo 06-03-2022 om 00:14
> [+0100]:
>> +             (("codecov>=2\\.1\\.8") "codecov")
>> +             (("pytest-cov>=2\\.10\\.0") "pytest-cov"))
> Instead of ignoring upstream's lower bound on the versions,
> how about updating the dependencies in Guix?

I updated both of these to the latest available version. Thank you,

Giacomo
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d3d7b7160d..5edfcca020 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3564,6 +3564,44 @@  (define-public python-jsondiff
 compare, diff, and patch JSON and JSON-like structures in Python.")
    (license license:expat)))
 
+(define-public python-ddlparse
+  (package
+    (name "python-ddlparse")
+    (version "1.10.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "ddlparse" version))
+        (sha256
+          (base32 "1nh8m6rxslwk05daxshxmgk41qfp18yynydba49b13l4m8dnh634"))
+       (modules '((guix build utils)))
+       (snippet
+        '(begin
+           (substitute* "test-requirements.txt"
+             (("codecov>=2\\.1\\.8") "codecov")
+             (("pytest-cov>=2\\.10\\.0") "pytest-cov"))
+           #t))))
+    (build-system python-build-system)
+    (arguments
+     `(#:phases (modify-phases %standard-phases
+                  (replace 'check
+                    (lambda* (#:key tests? #:allow-other-keys)
+                      (when tests?
+                        (invoke "pytest")))))))
+    (native-inputs
+     (list python-codeclimate-test-reporter
+           python-codecov
+           python-coveralls
+           python-pytest
+           python-pytest-cov
+           python-tox))
+    (propagated-inputs (list python-pyparsing))
+    (home-page "https://github.com/shinichi-takii/ddlparse")
+    (synopsis "Parses and converts DDL to BigQuery JSON schema")
+    (description "This package provides @{ddlparse}, a Python library to parse
+and convert DDL to BigQuery JSON schema.")
+    (license license:bsd-3)))
+
 (define-public python-jsonschema
   (package
     (name "python-jsonschema")