diff mbox series

[bug#54264] gnu: socat: Update to 1.7.4.3.

Message ID 20220305172451.11968-1-jgart@dismail.de
State Accepted
Headers show
Series [bug#54264] gnu: socat: Update to 1.7.4.3. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

jgart March 5, 2022, 5:24 p.m. UTC
* gnu/packages/networking.scm (socat): Update to 1.7.4.3.
---
 gnu/packages/networking.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Guillaume Le Vaillant March 8, 2022, 1:50 p.m. UTC | #1
Patch pushed as 3cd42883c4ad693ed1f79c6be35e1aa3e010e10a.
Thanks.
Ludovic Courtès March 8, 2022, 4:29 p.m. UTC | #2
Hello,

help-debbugs@gnu.org (GNU bug Tracking System) skribis:

> Patch pushed as 3cd42883c4ad693ed1f79c6be35e1aa3e010e10a.

I reverted it in 0e91da1d34250650f7549595867e1be4f8e93fd8 because it
triggered a massive rebuild:

--8<---------------cut here---------------start------------->8---
$ guix refresh -l socat
Building the following 6713 packages would ensure 13327 dependent
packages are rebuilt: […]
--8<---------------cut here---------------end--------------->8---

This is because GnuTLS depends on socat:

  guix graph -t reverse-package socat -M2 | xdot -f fdp -

So I think this should go to core-updates, or we could define a variant
for this new version but leave the ‘socat’ variable unchanged.

Thoughts?

Ludo’.
Guillaume Le Vaillant March 8, 2022, 4:42 p.m. UTC | #3
Ludovic Courtès <ludo@gnu.org> skribis:

> Hello,
>
> help-debbugs@gnu.org (GNU bug Tracking System) skribis:
>
>> Patch pushed as 3cd42883c4ad693ed1f79c6be35e1aa3e010e10a.
>
> I reverted it in 0e91da1d34250650f7549595867e1be4f8e93fd8 because it
> triggered a massive rebuild:
>
> $ guix refresh -l socat
> Building the following 6713 packages would ensure 13327 dependent
> packages are rebuilt: […]
>
> This is because GnuTLS depends on socat:
>
>   guix graph -t reverse-package socat -M2 | xdot -f fdp -
>
> So I think this should go to core-updates, or we could define a variant
> for this new version but leave the ‘socat’ variable unchanged.
>
> Thoughts?
>
> Ludo’.

Ah, yes I forgot to check the number of dependents before pushing.
I guess it should go on core-updates.
Guillaume Le Vaillant March 11, 2022, 9:58 a.m. UTC | #4
Patch pushed as 9223b81071ac5c18c94dce17c1fb6544016aac3d on
core-updates.
jgart March 11, 2022, 9:03 p.m. UTC | #5
On Fri, 11 Mar 2022 09:58:44 +0000 Guillaume Le Vaillant <glv@posteo.net> wrote:
> Patch pushed as 9223b81071ac5c18c94dce17c1fb6544016aac3d on
> core-updates.

Hi Guillaume,

Sorry I couldn't get to that on time but thanks for pushing it to core-updates.

all best,

jgart

https://whereis.xn--q9jyb4c
gemini://whereis.xn--q9jyb4c
diff mbox series

Patch

diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 11f1cad007..cf6e9c742f 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -951,7 +951,7 @@  (define-public pproxy
 (define-public socat
   (package
     (name "socat")
-    (version "1.7.4.1")
+    (version "1.7.4.3")
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -959,7 +959,7 @@  (define-public socat
                     version ".tar.bz2"))
               (sha256
                (base32
-                "1sbmqqvni3ss9wyay6ik5v81kxffkra80mh4ypgj74g82iba5b1z"))))
+                "01w0hpqf5xmgn40s1ablfd4y67dlrx5y9zlx24spc1qm8h81hwyl"))))
     (build-system gnu-build-system)
     (arguments '(#:tests? #f))          ; no test suite
     (inputs (list openssl))