diff mbox series

[bug#54231] gnu: trezor-agent: Fix it by deleting the sanity-check phase.

Message ID 20220303105801.3187-1-attila@lendvai.name
State Accepted
Headers show
Series [bug#54231] gnu: trezor-agent: Fix it by deleting the sanity-check phase. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Attila Lendvai March 3, 2022, 10:58 a.m. UTC
It used to work before the new sanity_check.py was added, and the build result
still seems to work fine.
---
 gnu/packages/finance.scm | 1 +
 1 file changed, 1 insertion(+)

Comments

M March 3, 2022, 12:28 p.m. UTC | #1
Attila Lendvai schreef op do 03-03-2022 om 11:58 [+0100]:
> +         (delete 'sanity-check) ; TODO It fails, but the package works fine.

How does it fail?  Maybe it indicates a real problem that merely
happens to be difficult to trigger in practice.

Greetings,
Maxime.
Attila Lendvai March 3, 2022, 2:24 p.m. UTC | #2
> > +         (delete 'sanity-check) ; TODO It fails, but the package works fine.
>
> How does it fail? Maybe it indicates a real problem that merely
> happens to be difficult to trigger in practice.


unfortunately i'm not a python expert, i don't know why it fails, but currently it doesn't even build.

i have attached the relevant part of the build output.

if you scan python-xyz.scm, this phase is deleted in several other packages.

--
• attila lendvai
• PGP: 963F 5D5F 45C7 DFCD 0A39
--
“There is nothing sacrosanct about the majority; the lynch mob, too, is the majority in its own domain.”
	— Murray N. Rothbard (1926–1995), 'For a New Liberty' (1973)
Marek Paśnikowski March 30, 2022, 1:29 p.m. UTC | #3
Greetings

I am a Guix newbie, so I do not know yet, how to find the package
source.

Does this package declare `python-trezor-agent` as a dependency? The
error message hints at this missing dependency.
Attila Lendvai April 12, 2022, 10:41 a.m. UTC | #4
would it be possible to get this in? or another fix that restores the
package's buildability?

the tests can be fixed later by a python expert that wanders around
here.

--
• attila lendvai
• PGP: 963F 5D5F 45C7 DFCD 0A39
--
“It is the mark of an educated mind to be able to entertain a thought without accepting it.”
	— Aristotle (BC 384–322), 'Metaphysics'
M April 12, 2022, 11:11 a.m. UTC | #5
Attila Lendvai schreef op di 12-04-2022 om 10:41 [+0000]:
> would it be possible to get this in? or another fix that restores the
> package's buildability?
> 
> the tests can be fixed later by a python expert that wanders around
> here.

It looks like 'trezor-agent' only has a python script and not a python
module, so no wonder that 'sanity-check' fails to find the module.  As
such, I believe that the 'sanity-check' phase can indeed be removed in
this case, if accompanied an appropriate comment.

Greetings,
Maxime.
Guillaume Le Vaillant April 12, 2022, 12:04 p.m. UTC | #6
Patch pushed as d3d2881acf4f3efef61a4049ea4c7c3ba883f48c with a comment
explaining why the 'sanity-check' phase is deleted.
Thanks.
M April 12, 2022, 12:29 p.m. UTC | #7
Marek Paśnikowski schreef op wo 30-03-2022 om 15:29 [+0200]:
> Does this package declare `python-trezor-agent` as a dependency? The
> error message hints at this missing dependency.

Yes, it does:

    (inputs
     (list python-trezor python-trezor-agent))

Greetings,
Maxime.
diff mbox series

Patch

diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 985eaa87f7..26c546caed 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -1156,6 +1156,7 @@  (define-public trezor-agent
     (arguments
      `(#:phases
        (modify-phases %standard-phases
+         (delete 'sanity-check) ; TODO It fails, but the package works fine.
          (add-after 'wrap 'fixup-agent-py
            (lambda* (#:key inputs outputs #:allow-other-keys)
              (let* ((out (assoc-ref outputs "out")))