diff mbox series

[bug#54036,v3] gnu: gnunet: Update to 0.16.0.

Message ID 20220302163503.5467-1-tanguy@bioneland.org
State Accepted
Headers show
Series [bug#54036,v3] gnu: gnunet: Update to 0.16.0. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Tanguy LE CARROUR March 2, 2022, 4:35 p.m. UTC
Hi Maxim,

Unfortunately, this is still a WIP.

I've reported the make-status-code problem upstream [1]. If it's a
problem on GNUnet's side, I'll try to fix it. If returning 2 is the
expected behaviour, I'll probably need some help to figure out what has
to be done on our side.

[1]: https://bugs.gnunet.org/view.php?id=7182

Regards,


* gnu/packages/gnunet.scm (gnunet): Update to 0.16.0.
[arguments] Enable all the tests that were disabled.
[inputs] Use new style. [home-page] Update URL.
---
 gnu/packages/gnunet.scm | 78 ++++++++++++++---------------------------
 1 file changed, 27 insertions(+), 51 deletions(-)

Comments

Ludovic Courtès March 6, 2022, 9:21 p.m. UTC | #1
Hi,

Tanguy Le Carrour <tanguy@bioneland.org> skribis:

> Unfortunately, this is still a WIP.
>
> I've reported the make-status-code problem upstream [1]. If it's a
> problem on GNUnet's side, I'll try to fix it. If returning 2 is the
> expected behaviour, I'll probably need some help to figure out what has
> to be done on our side.

I think 0.16.1 was released; does it help?

Thanks,
Ludo’.
Tanguy LE CARROUR March 7, 2022, 1:28 p.m. UTC | #2
Hi,


Quoting Ludovic Courtès (2022-03-06 22:21:13)
> Tanguy Le Carrour <tanguy@bioneland.org> skribis:
> 
> > Unfortunately, this is still a WIP.
> >
> > I've reported the make-status-code problem upstream [1]. If it's a
> > problem on GNUnet's side, I'll try to fix it. If returning 2 is the
> > expected behaviour, I'll probably need some help to figure out what has
> > to be done on our side.
> 
> I think 0.16.1 was released; does it help?

Nope! Unfortunately, a file is missing from the archive. :-(
Upstream provided me with a not-officially-published-version-0.16.1-3-g1f240bd13
to try out. It's building…

As I know which file is missing, I can write a package definition for 0.16.1
and create the file on the fly before running the checks, or…
We could also decide to wait for the 0.16.2 that will fix the problem.
diff mbox series

Patch

diff --git a/gnu/packages/gnunet.scm b/gnu/packages/gnunet.scm
index 1c09c9047b..9454407bfc 100644
--- a/gnu/packages/gnunet.scm
+++ b/gnu/packages/gnunet.scm
@@ -254,7 +254,7 @@  (define-public gnurl
 (define-public gnunet
   (package
    (name "gnunet")
-   (version "0.13.1")
+   (version "0.16.0")
    (source
     (origin
       (method url-fetch)
@@ -262,32 +262,32 @@  (define-public gnunet
                           ".tar.gz"))
       (sha256
        (base32
-        "15jnca5zxng7r6m3qzq9lr73xxq0v6mvcp0lny3zrlkz5s2nmmq3"))))
+        "0s006sdcczx7w1h9h1pnwwnnvxz9g47yl6apa9q8dkgi7zqscbfk"))))
    (build-system gnu-build-system)
    (inputs
-    `(("bluez" ,bluez)
-      ("glpk" ,glpk)
-      ("gnurl" ,gnurl)
-      ("gnutls" ,gnutls/dane)
-      ("gstreamer" ,gstreamer)
-      ("jansson" ,jansson)
-      ("libextractor" ,libextractor)
-      ("libidn" ,libidn2)
-      ("libgcrypt" ,libgcrypt)
-      ("libjpeg" ,libjpeg-turbo)
-      ("libltdl" ,libltdl)
-      ("libmicrohttpd" ,libmicrohttpd)
-      ("libogg" ,libogg)
-      ("libsodium" ,libsodium)
-      ("libunistring" ,libunistring)
-      ("miniupnpc" ,miniupnpc)
-      ("opus" ,opus)
-      ("pulseaudio" ,pulseaudio)
-      ("sqlite" ,sqlite)
-      ("zbar" ,zbar)
-      ("zlib" ,zlib)))
+    (list bluez
+          glpk
+          gnurl
+          gnutls/dane
+          gstreamer
+          jansson
+          libextractor
+          libidn2
+          libgcrypt
+          libjpeg-turbo
+          libltdl
+          libmicrohttpd
+          libogg
+          libsodium
+          libunistring
+          miniupnpc
+          opus
+          pulseaudio
+          sqlite
+          zbar
+          zlib))
    (native-inputs
-    (list curl pkg-config python xxd
+    (list curl openssl pkg-config python xxd
           (@ (gnu packages base) which)))
    (arguments
     '(#:parallel-tests? #f ; Parallel tests aren't supported.
@@ -296,32 +296,8 @@  (define-public gnunet
         (add-after 'configure 'remove-failing-tests
           ;; These tests fail in Guix's building environment.
           (lambda _
-            (substitute* "src/transport/Makefile"
-              (("\\$\\(am__EXEEXT_15\\)") "") ; test_transport_api_https
-              (("test_transport_api_manipulation_cfg\\$\\(EXEEXT\\) \\\\\n") "")
-              (("test_transport_api_udp_nat\\$\\(EXEEXT\\) \\\\\n") "")
-              (("test_transport_blacklisting_multiple_plugins\\$\\(EXEEXT\\) \\\\\n") ""))
-            (substitute* "src/testbed/Makefile"
-              (("test_testbed_api_2peers_1controller\\$\\(EXEEXT\\) \\\\\n") "")
-              (("test_testbed_api_statistics\\$\\(EXEEXT\\) \\\\\n") "")
-              (("test_testbed_api_test\\$\\(EXEEXT\\) \\\\\n") "")
-              (("test_testbed_api_test_timeout\\$\\(EXEEXT\\) \\\\\n") "")
-              (("test_testbed_api_topology\\$\\(EXEEXT\\) \\\\\n") "")
-              (("test_testbed_api_topology_clique\\$\\(EXEEXT\\) \\\\\n") ""))
-            (substitute* "src/topology/Makefile"
-              (("^check_PROGRAMS.*") "\n")
-              (("test_gnunet_daemon_topology\\$\\(EXEEXT\\)\n") ""))
-            (substitute* "src/namestore/Makefile"
-              (("\\$\\(am__append_2\\)") ""))
-            (substitute* "src/gns/Makefile"
-              (("\\$\\(am__append_4\\)") ""))
-            (substitute* "contrib/Makefile"
-              (("^check_PROGRAMS.*") "\n"))
-            ;; 'test' from coreutils doesn't behave as the test expects.
-            (substitute* '("src/gns/gnunet-gns-proxy-setup-ca.in"
-                           "src/transport/gnunet-transport-certificate-creation.in")
-              (("gnutls-certtool") "certtool"))
-            #t))
+            (substitute* "src/dht/test_dht_tools.py"
+              (("/usr/bin/python") (which "python3")))))
         (add-before 'check 'set-env-var-for-tests
           (lambda _
             (setenv "LANG" "en_US.UTF-8")))
@@ -344,7 +320,7 @@  (define-public gnunet
 an application for secure publication of files, it has grown to include all
 kinds of basic applications for the foundation of a GNU internet.")
    (license license:agpl3+)
-   (home-page "https://gnunet.org/")))
+   (home-page "https://gnunet.org/en/")))
 
 (define-public guile-gnunet                       ;GSoC 2015!
   (let ((commit "d12167ab3c8d7d6caffd9c606e389ef043760602")