diff mbox series

[bug#54182] gnu: foot: Add TERMINFO_DIRS to the search paths

Message ID 20220227143701.10949-1-kevinboulain@gmail.com
State Accepted
Headers show
Series [bug#54182] gnu: foot: Add TERMINFO_DIRS to the search paths | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Kevin Boulain Feb. 27, 2022, 2:37 p.m. UTC
A few other terminals in this file already do that to expose the
terminfo database. Without it, other programs will complain about
the "unknown terminal: foot".

* gnu/packages/terminals.scm (foot): Export TERMINFO_DIRS.
---
 gnu/packages/terminals.scm | 6 ++++++
 1 file changed, 6 insertions(+)

Comments

M Feb. 27, 2022, 3:42 p.m. UTC | #1
This appears to be a duplicate of #53257
(https://issues.guix.gnu.org/53257)
Kevin Boulain Feb. 27, 2022, 5:23 p.m. UTC | #2
Oh, my bad, I guess I can't search :)
I see that some discussion has already happened and a proper solution
isn't as simple as that. Let's close this one then.

On Sun, 27 Feb 2022 at 16:42, Maxime Devos <maximedevos@telenet.be> wrote:
>
> This appears to be a duplicate of #53257
> (https://issues.guix.gnu.org/53257)
diff mbox series

Patch

diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index 06fa341472..a9500d6626 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -858,6 +858,12 @@  (define-public foot
            pkg-config scdoc wayland-protocols))
     (inputs
      (list fcft libxkbcommon wayland))
+    (native-search-paths
+     ;; FIXME: This should only be located in 'ncurses'.  Nonetheless it is
+     ;; provided for usability reasons.  See <https://bugs.gnu.org/22138>.
+     (list (search-path-specification
+            (variable "TERMINFO_DIRS")
+            (files '("share/terminfo")))))
     (synopsis "Wayland-native terminal emulator")
     (description
      "@command{foot} is a terminal emulator for systems using the Wayland