diff mbox series

[bug#54104] gnu: Add fcitx5-anthy

Message ID 20220222001349.24808-2-dom@dominicm.dev
State Accepted
Headers show
Series [bug#54104] gnu: Add fcitx5-anthy | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Dominic Martinez Feb. 22, 2022, 12:13 a.m. UTC
From: Dominic Martinez <dom@dominicm.dev>

* gnu/packages/fcitx5.scm (fcitx5-anthy): New variable.
---
 gnu/packages/fcitx5.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)

Comments

Dominic Martinez March 9, 2022, 3:47 p.m. UTC | #1
Just wanted to ping this patch; I've tested this on my personal 
fcitx5 setup and it works, so unless there is a formatting issue I 
think this is good to merge.
Nicolas Goaziou March 10, 2022, 6:59 p.m. UTC | #2
Hello,

dom@dominicm.dev writes:

> * gnu/packages/fcitx5.scm (fcitx5-anthy): New variable.

Applied. Thank you.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/fcitx5.scm b/gnu/packages/fcitx5.scm
index 0be5e53863..13031d6d3d 100644
--- a/gnu/packages/fcitx5.scm
+++ b/gnu/packages/fcitx5.scm
@@ -1,6 +1,7 @@ 
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2020, 2022 Zhu Zihao <all_but_last@163.com>
 ;;; Copyright © 2021 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2022 Dominic Martinez <dom@dominicm.dev>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -25,6 +26,7 @@  (define-module (gnu packages fcitx5)
   #:use-module (guix build-system cmake)
   #:use-module (guix build-system copy)
   #:use-module ((guix licenses) #:prefix license:)
+  #:use-module (gnu packages anthy)
   #:use-module (gnu packages boost)
   #:use-module (gnu packages curl)
   #:use-module (gnu packages datastructures)
@@ -288,6 +290,30 @@  (define-public fcitx5-qt
                    ;; and qt5/platforminputcontext.
                    license:bsd-3))))
 
+(define-public fcitx5-anthy
+  (package
+    (name "fcitx5-anthy")
+    (version "5.0.9")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://download.fcitx-im.org/fcitx5"
+                           "/fcitx5-anthy/fcitx5-anthy-"
+                           version ".tar.xz"))
+       (sha256
+        (base32 "0i2ahfp1vh0cs3brcsfblzqwszal2qj1ncgb1hbc9v03s1j6bybk"))))
+    (build-system cmake-build-system)
+    (arguments
+     `(#:tests? #f)) ;; no tests
+    (inputs (list fcitx5 anthy gettext-minimal fmt))
+    (native-inputs
+     (list extra-cmake-modules pkg-config))
+    (home-page "https://github.com/fcitx/fcitx5-anthy")
+    (synopsis "Anthy Japanese language input for Fcitx 5")
+    (description "Fcitx5-Anthy provides Japanese input support to Fcitx5 using
+the Anthy input method.")
+    (license license:gpl2+)))
+
 (define-public fcitx5-chinese-addons
   (package
     (name "fcitx5-chinese-addons")