diff mbox series

[bug#54093] gnu: Add emacs-sink-el.

Message ID 20220221203644.13746-1-jgart@dismail.de
State Accepted
Headers show
Series [bug#54093] gnu: Add emacs-sink-el. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

jgart Feb. 21, 2022, 8:36 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-sink-el): New variable.
---

Hi Guixers,

Let me know if you think this is ready for upstream.

I have it packaged as a pre-release in Guix 'R Us.

all best,

jgart

gemini://whereis.xn--q9jyb4c/
https://whereis.xn--q9jyb4c/

 gnu/packages/emacs-xyz.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

Comments

Nicolas Goaziou Feb. 22, 2022, 10:40 a.m. UTC | #1
Hello,

jgart via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/emacs-xyz.scm (emacs-sink-el): New variable.

Thank you.

This relies on the "9p" executable, but I don't think we packaged it so
far. If we do, it should be provided as an input.

WDYT?

Regards,
jgart Feb. 22, 2022, 7:55 p.m. UTC | #2
On Tue, 22 Feb 2022 11:40:25 +0100 Nicolas Goaziou <mail@nicolasgoaziou.fr> wrote:
> This relies on the "9p" executable, but I don't think we packaged it so
> far. If we do, it should be provided as an input.
> WDYT?

Sounds good to me. 

9p comes from:

https://github.com/9fans/plan9port/blob/master/src/cmd/9p.c

I'll try to package that soon.

Thanks for the review!

all best,

jgart

gemini://whereis.xn--q9jyb4c/
https://whereis.xn--q9jyb4c/
Maxim Cournoyer July 7, 2022, 8:14 p.m. UTC | #3
Hi jgart,

jgart <jgart@dismail.de> writes:

> On Tue, 22 Feb 2022 11:40:25 +0100 Nicolas Goaziou <mail@nicolasgoaziou.fr> wrote:
>> This relies on the "9p" executable, but I don't think we packaged it so
>> far. If we do, it should be provided as an input.
>> WDYT?
>
> Sounds good to me. 
>
> 9p comes from:
>
> https://github.com/9fans/plan9port/blob/master/src/cmd/9p.c
>
> I'll try to package that soon.

OK.  Please send a new submission when you get around to it.  Closing
for now.

Thank you!

Maxim
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 3b909b8d0d..dc2bd198e3 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -30677,6 +30677,30 @@  (define-public emacs-alsamixer-el
 audio volume via amixer.")
     (license license:gpl3+)))
 
+(define-public emacs-sink-el
+  (let ((commit "d64ee23df974851352c48d17eeeb9376c40779a9")
+        (revision "0"))
+    (package
+      (name "emacs-sink-el")
+      (version (git-version "0.1" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri
+          (git-reference
+           (url "https://github.com/alcah/sink.el")
+           (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "1bshm19cbsjn100nfjz2anmpgp9yml88701nfdal9a2b7g6dr5x9"))))
+      (build-system emacs-build-system)
+      (home-page "https://github.com/alcah/sink.el")
+      (synopsis "Receive messages from Plan9's plumber in Emacs")
+      (description
+"@code{sink.el} provides a global minor mode allowing Emacs to receive and
+respond to messages from the Plan9 plumber via its ports interface.")
+      (license license:unlicense))))
+
 (define-public emacs-fennel-mode
   (package
     (name "emacs-fennel-mode")