[bug#53878,v4,03/15] gnu: chez-scheme: Use shared zlib and lz4.
Commit Message
This change also involves building 'libkernel.a' instead of 'kernel.o'.
Support for these build options was merged upstream in 2019: see
discussion at <https://github.com/cisco/ChezScheme/pull/443>.
* gnu/packages/chez-and-racket-bootstrap (chez-scheme)[inputs]: Remove
'zlib:static' and 'lz4:static'.
[arguments]: Adjust configure phase accordingly.
---
gnu/packages/chez-and-racket-bootstrap.scm | 18 ++++++++----------
1 file changed, 8 insertions(+), 10 deletions(-)
@@ -114,9 +114,7 @@ (define-public chez-scheme
(inputs
`(("libuuid" ,util-linux "lib")
("zlib" ,zlib)
- ("zlib:static" ,zlib "static")
("lz4" ,lz4)
- ("lz4:static" ,lz4 "static")
;; for expeditor:
("ncurses" ,ncurses)
;; for X11 clipboard support in expeditor:
@@ -169,14 +167,14 @@ (define src
(lz4-static (assoc-ref inputs "lz4:static"))
(out (assoc-ref outputs "out"))
;; add flags which are always required:
- (flags (cons*
- (string-append "--installprefix=" out)
- (string-append "ZLIB=" zlib-static "/lib/libz.a")
- (string-append "LZ4=" lz4-static "/lib/liblz4.a")
- ;; Guix will do compress man pages,
- ;; and letting Chez try causes an error
- "--nogzip-man-pages"
- configure-flags)))
+ (flags (cons* (string-append "--installprefix=" out)
+ "ZLIB=-lz"
+ "LZ4=-llz4"
+ "--libkernel"
+ ;; Guix will do compress-man-pages,
+ ;; and letting Chez try causes an error
+ "--nogzip-man-pages"
+ configure-flags)))
(format #t "configure flags: ~s~%" flags)
;; Some makefiles (for tests) don't seem to propagate CC
;; properly, so we take it out of their hands: