diff mbox series

[bug#54054] gnu: mercury: Remove trailing #T from phases and snippet.

Message ID 20220218061613.17133-1-jgart@dismail.de
State Accepted
Headers show
Series [bug#54054] gnu: mercury: Remove trailing #T from phases and snippet. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

jgart Feb. 18, 2022, 6:16 a.m. UTC
* gnu/packages/mercury.scm (mercury)[arguments]<#:phases>: Remove trailing #T.
---
 gnu/packages/mercury.scm | 12 ++++--------
 1 file changed, 4 insertions(+), 8 deletions(-)

Comments

Mathieu Othacehe March 29, 2022, 9:20 a.m. UTC | #1
> * gnu/packages/mercury.scm (mercury)[arguments]<#:phases>: Remove trailing #T.

Pushed, thanks!

Mathieu
diff mbox series

Patch

diff --git a/gnu/packages/mercury.scm b/gnu/packages/mercury.scm
index fe02b34a97..c87e65fdd1 100644
--- a/gnu/packages/mercury.scm
+++ b/gnu/packages/mercury.scm
@@ -100,8 +100,7 @@  (define-public mercury-minimal
                        (invoke "mv" orig-name new-name)
                        (with-directory-excursion new-name
                          (apply patch-source-shebangs (list #:source src)))))
-                    `((,libatomic-ops "source" "boehm_gc/libatomic_ops")))
-               #t)))
+                    `((,libatomic-ops "source" "boehm_gc/libatomic_ops"))))))
          (add-after 'replace-boehm-gc 'patch-paths
            (lambda _
              (substitute*
@@ -133,8 +132,7 @@  (define-public mercury-minimal
                        "boehm_gc/Makefile.direct")
                (("/bin/sh") (which "sh"))
                (("/bin/pwd") (which "pwd"))
-               (("/bin/rm") (which "rm")))
-             #t)))))
+               (("/bin/rm") (which "rm"))))))))
     (native-inputs
      `(("texinfo" ,texinfo)
        ("flex" ,flex)
@@ -227,12 +225,10 @@  (define-public mercury
                         (("/bin/sh") (which "sh"))
                         (("/bin/pwd") (which "pwd"))
                         (("/bin/rm") (which "rm"))
-                        (("boehm_gc/.git") "boehm_gc"))
-                      #t))
+                        (("boehm_gc/.git") "boehm_gc"))))
                   (replace 'bootstrap
                     (lambda _
-                      (invoke "./prepare.sh")
-                      #t))))))
+                      (invoke "./prepare.sh")))))))
            ;; TODO: Uncomment phase when tests are enabled.
            ;; (replace 'check
            ;;   (lambda _