diff mbox series

[bug#54052] gnu: cgdb: Add gdb to propagated-inputs

Message ID 20220218052005.10687-1-chadwainholness@gmail.com
State Accepted
Headers show
Series [bug#54052] gnu: cgdb: Add gdb to propagated-inputs | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Chadwain Holness Feb. 18, 2022, 5:20 a.m. UTC
* gnu/packages/debug.scm (cgdb)[propagated-inputs]: Add gdb
---
 gnu/packages/debug.scm | 2 ++
 1 file changed, 2 insertions(+)

Comments

M Feb. 18, 2022, 7:56 a.m. UTC | #1
Chadwain Holness schreef op vr 18-02-2022 om 00:20 [-0500]:
> +    (propagated-inputs
> +     (list gdb))

Propagation can lead to slower profile build times and propagation
conflicts.  Can it be depropagated by substituting 'gdb' with the
/gnu/store/... name?  (Look for "gdb" in fork_util.cpp and
'substitute*' from (guix build utils).)

Also, looking at the source code, I see "/bin/sh", can it also be
replaced?

Greetings,
Maxime.
diff mbox series

Patch

diff --git a/gnu/packages/debug.scm b/gnu/packages/debug.scm
index 24d17d95b0..89629e4aca 100644
--- a/gnu/packages/debug.scm
+++ b/gnu/packages/debug.scm
@@ -763,6 +763,8 @@  (define-public cgdb
      (list ncurses readline))
     (native-inputs
      (list flex texinfo))
+    (propagated-inputs
+     (list gdb))
     (home-page "https://cgdb.github.io")
     (synopsis "Console front-end to the GNU debugger")
     (description