diff mbox series

[bug#53966] gnu: udpcast: Update to 20211207.

Message ID 20220213050928.22409-1-mike@rohleder.de
State Accepted
Headers show
Series [bug#53966] gnu: udpcast: Update to 20211207. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Michael Rohleder Feb. 13, 2022, 5:09 a.m. UTC
* gnu/packages/admin.scm (udpcast): Update to 20211207.
[source]: Remove buildroot.net uri.
---
 gnu/packages/admin.scm | 9 +++------
 1 file changed, 3 insertions(+), 6 deletions(-)

Comments

M Feb. 13, 2022, 9:32 a.m. UTC | #1
Michael Rohleder schreef op zo 13-02-2022 om 06:09 [+0100]:
>         ;; XXX: Original server is at https://www.udpcast.linux.lu is
> not
>         ;; reliable.

Do you know in what sense it is unreliable?

>         (uri (list (string-append
> -                   "http://sources.buildroot.net/udpcast/udpcast-"
> -                   version ".tar.gz")
> -                  (string-append
>                     "https://fossies.org/linux/privat/udpcast-"
>                     version ".tar.gz")
>                    (string-append
>                     "https://www.udpcast.linux.lu/download/udpcast-"
>                     version ".tar.gz")))
> 


I noticed the old URI
<https://fossies.org/linux/privat/udpcast-20200328.tar.gz/>
now is a 404.  It seems like old versions are automatically removed,
so the fossies URL would be unreliable (from a reproducibility POV).

The only remaining URL is the www.udpcast.linux.lu URL.  It would be
nice to have more fallbacks, so personally I would keep the
sources.buildroot.net URL, even though it currently 404s, with a
comment like

  ;; At time of writing, sources.buildroot.net only has old versions
  ;; of udpcast, but presumably it will be updated eventually.

YMMV.

Greetings,
Maxime.
Michael Rohleder Feb. 13, 2022, 4:45 p.m. UTC | #2
Maxime Devos <maximedevos@telenet.be> writes:
> Michael Rohleder schreef op zo 13-02-2022 om 06:09 [+0100]:
>>         ;; XXX: Original server is at https://www.udpcast.linux.lu is
>> not
>>         ;; reliable.
>
> Do you know in what sense it is unreliable?

No.

>>         (uri (list (string-append
>> -                   "http://sources.buildroot.net/udpcast/udpcast-"
>> -                   version ".tar.gz")
>> -                  (string-append
>>                     "https://fossies.org/linux/privat/udpcast-"
>>                     version ".tar.gz")
>>                    (string-append
>>                     "https://www.udpcast.linux.lu/download/udpcast-"
>>                     version ".tar.gz")))
>> 
>
>
> I noticed the old URI
> <https://fossies.org/linux/privat/udpcast-20200328.tar.gz/>
> now is a 404.  It seems like old versions are automatically removed,
> so the fossies URL would be unreliable (from a reproducibility POV).

https://fossies.org/linux/privat/udpcast-20211207.tar.gz
seems to be available, so we have 2 uris.

>
> The only remaining URL is the www.udpcast.linux.lu URL.  It would be
> nice to have more fallbacks, so personally I would keep the
> sources.buildroot.net URL, even though it currently 404s, with a
> comment like
>
>   ;; At time of writing, sources.buildroot.net only has old versions
>   ;; of udpcast, but presumably it will be updated eventually.
>
> YMMV.

Ok.
Nicolas Goaziou Feb. 14, 2022, 9:57 a.m. UTC | #3
Hello,

Michael Rohleder <mike@rohleder.de> writes:

> * gnu/packages/admin.scm (udpcast): Update to 20211207.
> [source]: Remove buildroot.net uri.

Applied. Thank you.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index daab720be5..525a5fdb69 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -32,7 +32,7 @@ 
 ;;; Copyright © 2019, 2020, 2021 Mathieu Othacehe <m.othacehe@gmail.com>
 ;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
 ;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
-;;; Copyright © 2020, 2021 Michael Rohleder <mike@rohleder.de>
+;;; Copyright © 2020, 2021, 2022 Michael Rohleder <mike@rohleder.de>
 ;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
 ;;; Copyright © 2020 Morgan Smith <Morgan.J.Smith@outlook.com>
 ;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
@@ -4912,23 +4912,20 @@  (define-public runitor
 (define-public udpcast
   (package
     (name "udpcast")
-    (version "20200328")
+    (version "20211207")
     (source
      (origin
        (method url-fetch)
        ;; XXX: Original server is at https://www.udpcast.linux.lu is not
        ;; reliable.
        (uri (list (string-append
-                   "http://sources.buildroot.net/udpcast/udpcast-"
-                   version ".tar.gz")
-                  (string-append
                    "https://fossies.org/linux/privat/udpcast-"
                    version ".tar.gz")
                   (string-append
                    "https://www.udpcast.linux.lu/download/udpcast-"
                    version ".tar.gz")))
        (sha256
-        (base32 "06pj86nbi9hx7abbb0z2c5ynhfq0rv89b7nmy0kq3xz2lsxfw6cw"))))
+        (base32 "0l6hck694szrrvz85nm48rwb7mzvg2z2bwa50v51pkvym3kvxkm3"))))
     (build-system gnu-build-system)
     (native-inputs
      (list autoconf automake m4 perl))