diff mbox series

[bug#53872] gnu: maven: Use required logger

Message ID 20220208104231.415fc1ba@tachikoma.lepiller.eu
State Accepted
Headers show
Series [bug#53872] gnu: maven: Use required logger | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Julien Lepiller Feb. 8, 2022, 9:42 a.m. UTC
Hi Guix!

I figured there was a small issue with our maven package. It warns that
the current logger is not supported, and lists no supported logger.
This is because I forgot to copy resources in maven-embedder (first
patch). I also noticed I missed resources in maven-compat, so I fixed
that in the second patch.

Then, maven uses its own logger instead of a default one, even if it
does support slf4j-simple. The third patch adds maven-slf4j-wrapper. It
is essentially a fork of slf4j-simple, but the way it's written
requires me to copy most of slf4j-simple's sources. The last patch
switches the use of slf4j-simple to maven-slf4j-provider. I checked
that java-jmh still builds properly with this change, and no warnings
are shown about the logger anymore.

Comments

Ludovic Courtès Feb. 16, 2022, 3:03 p.m. UTC | #1
Hi,

Julien Lepiller <julien@lepiller.eu> skribis:

> I figured there was a small issue with our maven package. It warns that
> the current logger is not supported, and lists no supported logger.
> This is because I forgot to copy resources in maven-embedder (first
> patch). I also noticed I missed resources in maven-compat, so I fixed
> that in the second patch.
>
> Then, maven uses its own logger instead of a default one, even if it
> does support slf4j-simple. The third patch adds maven-slf4j-wrapper. It
> is essentially a fork of slf4j-simple, but the way it's written
> requires me to copy most of slf4j-simple's sources. The last patch
> switches the use of slf4j-simple to maven-slf4j-provider. I checked
> that java-jmh still builds properly with this change, and no warnings
> are shown about the logger anymore.

I know nothing about Maven but I’d say you can go ahead if the other
Java folks around here have nothing to say.
(When do we set up teams? :-))

Thanks,
Ludo’.
Julien Lepiller Feb. 28, 2022, 10 a.m. UTC | #2
With no other answer after more than two weeks since I posted the patch
series, pushed to master as ea23386e084a035e4bc23273fffc3d114b311789 -
9aae8a3e0d53fd0c11b8e98e1fd2d2232598b036. Thanks!

Le Wed, 16 Feb 2022 16:03:23 +0100,
Ludovic Courtès <ludo@gnu.org> a écrit :

> Hi,
> 
> Julien Lepiller <julien@lepiller.eu> skribis:
> 
> > I figured there was a small issue with our maven package. It warns
> > that the current logger is not supported, and lists no supported
> > logger. This is because I forgot to copy resources in
> > maven-embedder (first patch). I also noticed I missed resources in
> > maven-compat, so I fixed that in the second patch.
> >
> > Then, maven uses its own logger instead of a default one, even if it
> > does support slf4j-simple. The third patch adds
> > maven-slf4j-wrapper. It is essentially a fork of slf4j-simple, but
> > the way it's written requires me to copy most of slf4j-simple's
> > sources. The last patch switches the use of slf4j-simple to
> > maven-slf4j-provider. I checked that java-jmh still builds properly
> > with this change, and no warnings are shown about the logger
> > anymore.  
> 
> I know nothing about Maven but I’d say you can go ahead if the other
> Java folks around here have nothing to say.
> (When do we set up teams? :-))
> 
> Thanks,
> Ludo’.
diff mbox series

Patch

From e7fe8f9973b32d8f6114dbf4aee3807adf2c8fb5 Mon Sep 17 00:00:00 2001
Message-Id: <e7fe8f9973b32d8f6114dbf4aee3807adf2c8fb5.1644313064.git.julien@lepiller.eu>
In-Reply-To: <6af76778dd0fb3436e673ee00984fb87fb72cdde.1644313064.git.julien@lepiller.eu>
References: <6af76778dd0fb3436e673ee00984fb87fb72cdde.1644313064.git.julien@lepiller.eu>
From: Julien Lepiller <julien@lepiller.eu>
Date: Tue, 8 Feb 2022 10:32:32 +0100
Subject: [PATCH 4/4] gnu: maven: Use maven-slf4j-provider instead of
 slf4j-simple.

Maven uses its own slf4j implementation, not the default one.  The main
difference is the color on the output.

* gnu/packages/maven.scm (maven-wagon-http, maven-embedder, maven-compat)
(maven): Replace slf4j-simple with maven-slf4j-provider.
---
 gnu/packages/maven.scm | 17 ++++++++---------
 1 file changed, 8 insertions(+), 9 deletions(-)

diff --git a/gnu/packages/maven.scm b/gnu/packages/maven.scm
index cf07c08b8e..edf93f276b 100644
--- a/gnu/packages/maven.scm
+++ b/gnu/packages/maven.scm
@@ -1088,6 +1088,7 @@  (define-public maven-wagon-http
        ("java-plexus-cli" ,java-plexus-cli)
        ("maven-plugin-api" ,maven-plugin-api)
        ("maven-plugin-annotations" ,maven-plugin-annotations)
+       ("maven-slf4j-provider" ,maven-slf4j-provider)
        ("maven-core" ,maven-core)
        ("maven-model" ,maven-model)
        ("java-commons-cli" ,java-commons-cli)
@@ -1106,7 +1107,6 @@  (define-public maven-wagon-http
        ("java-commons-codec" ,java-commons-codec)
        ("java-commons-io" ,java-commons-io)
        ("java-jsoup" ,java-jsoup)
-       ("java-slf4j-simple" ,java-slf4j-simple)
        ,@(package-native-inputs maven-wagon-provider-api)))
     (synopsis "Wagon provider that gets and puts artifacts through HTTP(S)")
     (description "Maven Wagon is a transport abstraction that is used in Maven's
@@ -1874,6 +1874,7 @@  (define-public maven-embedder
        ("maven-settings" ,maven-settings)
        ("maven-settings-builder" ,maven-settings-builder)
        ("maven-shared-utils" ,maven-shared-utils)
+       ("maven-slf4j-provider" ,maven-slf4j-provider)
        ("java-plexus-classworlds" ,java-plexus-classworlds)
        ("java-plexus-util" ,java-plexus-utils)
        ("java-eclipse-sisu-plexus" ,java-eclipse-sisu-plexus)
@@ -1891,7 +1892,6 @@  (define-public maven-embedder
        ("java-guice" ,java-guice)
        ("java-javax-inject" ,java-javax-inject)
        ("java-slf4j-api" ,java-slf4j-api)
-       ("java-slf4j-simple" ,java-slf4j-simple)
        ("java-jsr250" ,java-jsr250)))
     (native-inputs
      `(("java-asm-8" ,java-asm-8)
@@ -2122,8 +2122,8 @@  (define-public maven-compat
        ("java-commons-lang3" ,java-commons-lang3)
        ("java-aop" ,java-aopalliance)
        ("maven-resolver-provider" ,maven-resolver-provider)
+       ("maven-slf4j-provider" ,maven-slf4j-provider)
        ("java-slf4j-api" ,java-slf4j-api)
-       ("java-slf4j-simple" ,java-slf4j-simple)
        ,@(package-inputs java-slf4j-api)))
     (description "Apache Maven is a software project management and comprehension
 tool.  This package contains Maven2 classes maintained as compatibility
@@ -2161,7 +2161,8 @@  (define-public maven
                      "maven-repository-metadata" "maven-shared-utils" "maven-resolver-api"
                      "maven-resolver-spi" "maven-resolver-util" "maven-resolver-impl"
                      "maven-resolver-connector-basic" "maven-resolver-provider"
-                     "maven-resolver-transport-wagon" "maven-wagon-provider-api"
+                     "maven-resolver-transport-wagon" "maven-slf4j-provider"
+                     "maven-wagon-provider-api"
                      "maven-wagon-file" "maven-wagon-http" "java-commons-logging-minimal"
                      "java-httpcomponents-httpclient" "java-httpcomponents-httpcore"
                      "maven-wagon-http-shared" "maven-wagon-tck-http"
@@ -2171,8 +2172,7 @@  (define-public maven
                      "java-plexus-utils" "java-plexus-interpolation"
                      "java-plexus-sec-dispatcher" "java-plexus-cipher" "java-guava"
                      "java-jansi" "java-jsr250" "java-cdi-api" "java-commons-cli"
-                     "java-commons-io" "java-commons-lang3" "java-slf4j-api"
-                     "java-slf4j-simple"))))
+                     "java-commons-io" "java-commons-lang3" "java-slf4j-api"))))
              (substitute* "apache-maven/src/bin/mvn"
                (("cygwin=false;")
                 (string-append
@@ -2218,6 +2218,7 @@  (define-public maven
            maven-resolver-connector-basic
            maven-resolver-provider
            maven-resolver-transport-wagon
+           maven-slf4j-provider
            maven-wagon-provider-api
            maven-wagon-file
            maven-wagon-http
@@ -2245,9 +2246,7 @@  (define-public maven
            java-commons-cli
            java-commons-io
            java-commons-lang3
-           java-slf4j-api
-           ;; TODO: replace with maven-slf4j-provider
-           java-slf4j-simple))
+           java-slf4j-api))
     (propagated-inputs
      (list coreutils which))
     (description "Apache Maven is a software project management and comprehension
-- 
2.34.0