diff mbox series

[bug#53860] gnu: clojure-data-xml: Fix build by removing tests.

Message ID 20220207193219.4055890-2-steve@futurile.net
State Accepted
Headers show
Series [bug#53860] gnu: clojure-data-xml: Fix build by removing tests. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Steve George Feb. 7, 2022, 7:32 p.m. UTC
* gnu/packages/clojure.scm (clojure-data-xml): tests don't work with stable and
recent versions of the JDK (https://clojure.atlassian.net/browse/DXML-67).
Prevent test build stage running.
---
 gnu/packages/clojure.scm | 7 +++++--
 1 file changed, 5 insertions(+), 2 deletions(-)


base-commit: abb197dfe98095a9ea7527a3ca3f81bb0edd5813

Comments

Julien Lepiller Feb. 8, 2022, 10:55 a.m. UTC | #1
Le Mon,  7 Feb 2022 19:32:19 +0000,
Steve George <steve@futurile.net> a écrit :

> * gnu/packages/clojure.scm (clojure-data-xml): tests don't work with
> stable and recent versions of the JDK
> (https://clojure.atlassian.net/browse/DXML-67). Prevent test build
> stage running. ---
>  gnu/packages/clojure.scm | 7 +++++--
>  1 file changed, 5 insertions(+), 2 deletions(-)
> 
> diff --git a/gnu/packages/clojure.scm b/gnu/packages/clojure.scm
> index 40a3d7708a..6f9dbd6bca 100644
> --- a/gnu/packages/clojure.scm
> +++ b/gnu/packages/clojure.scm
> @@ -333,10 +333,13 @@ is on par with Java implementations, e.g.,
> Apache commons-codec.") (arguments
>       '(#:source-dirs '("src/main/clojure")
>         #:test-dirs '("src/test/clojure")
> -       #:doc-dirs '()))
> +       #:doc-dirs '()
> +       ;; FIXME: resolve when
> https://clojure.atlassian.net/browse/DXML-67 is closed
> +       #:tests? #f))
>      (propagated-inputs (list clojure-data-codec))
>      (synopsis "Clojure library for reading and writing XML data")
> -    (description "@code{data.xml} is a Clojure library for reading
> and writing
> +    (description
> +     "@code{data.xml} is a Clojure library for reading and writing
>  XML data. @code{data.xml} has the following features:
>  
>  Parses XML documents into Clojure data structures
> 
> base-commit: abb197dfe98095a9ea7527a3ca3f81bb0edd5813

Thanks for the patch! Ryan had a better approach in
https://issues.guix.gnu.org/53868, so I pushed it instead. Disabling
only the failing test is better that disabling all tests :).

Closing this as the package is now fixed. Thanks!
Steve George Feb. 8, 2022, 11:03 a.m. UTC | #2
See #53868 which is better as it only stops cljs tests. 
(https://debbugs.gnu.org/cgi/bugreport.cgi?bug=53868)
diff mbox series

Patch

diff --git a/gnu/packages/clojure.scm b/gnu/packages/clojure.scm
index 40a3d7708a..6f9dbd6bca 100644
--- a/gnu/packages/clojure.scm
+++ b/gnu/packages/clojure.scm
@@ -333,10 +333,13 @@  is on par with Java implementations, e.g., Apache commons-codec.")
     (arguments
      '(#:source-dirs '("src/main/clojure")
        #:test-dirs '("src/test/clojure")
-       #:doc-dirs '()))
+       #:doc-dirs '()
+       ;; FIXME: resolve when https://clojure.atlassian.net/browse/DXML-67 is closed
+       #:tests? #f))
     (propagated-inputs (list clojure-data-codec))
     (synopsis "Clojure library for reading and writing XML data")
-    (description "@code{data.xml} is a Clojure library for reading and writing
+    (description
+     "@code{data.xml} is a Clojure library for reading and writing
 XML data. @code{data.xml} has the following features:
 
 Parses XML documents into Clojure data structures