diff mbox series

[bug#53829,v2] gnu: Add jj.

Message ID 20220207022752.19366-1-jgart@dismail.de
State Accepted
Headers show
Series [bug#53829,v2] gnu: Add jj. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

jgart Feb. 7, 2022, 2:27 a.m. UTC
* gnu/packages/messaging.scm (jj): New variable.
---

Hi,

Here is version two with the gexps.

thanks,

jgart

 gnu/packages/messaging.scm | 37 +++++++++++++++++++++++++++++++++++++
 1 file changed, 37 insertions(+)

Comments

Ludovic Courtès March 3, 2022, 10:44 p.m. UTC | #1
Hi,

jgart <jgart@dismail.de> skribis:

> * gnu/packages/messaging.scm (jj): New variable.

[...]

> +(define-public jj
> +    (package
> +      (name "jj")
> +      (version "2")

I passed it through ‘guix style’, …

> +      (arguments
> +       `(#:tests? #f ; There are no tests.
> +         #:make-flags
> +         ,#~(list (string-append "CC=" #$(cc-for-target))

… changed this to avoid ,#~

> +      (description

… and tweaked this.

Committed, thanks!

Ludo’.
jgart March 4, 2022, 12:21 a.m. UTC | #2
On Thu, 03 Mar 2022 23:44:13 +0100 Ludovic Courtès <ludo@gnu.org> wrote:
> I passed it through ‘guix style’, …
> 
> > +      (arguments
> > +       `(#:tests? #f ; There are no tests.
> > +         #:make-flags
> > +         ,#~(list (string-append "CC=" #$(cc-for-target))
> 
> … changed this to avoid ,#~
> 
> > +      (description
> 
> … and tweaked this.

Thank you Ludo! Much appreciated.

all best,

jgart
diff mbox series

Patch

diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 768642f119..751b9a9766 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -3118,6 +3118,43 @@  (define-public matterbridge
     (home-page "https://github.com/42wim/matterbridge")
     (license license:asl2.0)))
 
+(define-public jj
+    (package
+      (name "jj")
+      (version "2")
+      (source
+       (origin
+         (method url-fetch)
+         (uri (string-append "https://23.fi/jj/jj-" version ".tar.gz"))
+         (sha256
+          (base32 "02xz2ci93bccvil5iff804mh3zr5iqkf6zx5mxgraz17xg0azlgh"))))
+      (build-system gnu-build-system)
+      (arguments
+       `(#:tests? #f ; There are no tests.
+         #:make-flags
+         ,#~(list (string-append "CC=" #$(cc-for-target))
+                  (string-append "PREFIX=" #$output))
+         #:phases
+         (modify-phases %standard-phases
+           (delete 'configure)
+         (replace 'install
+           (lambda* (#:key inputs outputs #:allow-other-keys)
+             (let* ((out (assoc-ref outputs "out"))
+                    (bin (string-append out "/bin")))
+               (install-file "jj" bin)))))))
+      (native-inputs
+        (list pkg-config))
+      (inputs
+        (list glib loudmouth))
+      (home-page "https://23.fi/jj/")
+      (synopsis "FIFO based Jabber client")
+      (description
+"@command{jj} is a simple FIFO and filesystem based Jabber
+client.  @code{jj} is inspired by @code{ii} IRC client.  It is perfect
+for bots and notifications.  Interaction with jj is done by writing and
+reading files from the server directory which jj creates.")
+      (license license:expat)))
+
 (define-public pounce
   (package
     (name "pounce")