diff mbox series

[bug#53825,v2] gnu: Add sbase.

Message ID 20220207021717.16045-1-jgart@dismail.de
State Accepted
Headers show
Series [bug#53825,v2] gnu: Add sbase. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

jgart Feb. 7, 2022, 2:17 a.m. UTC
* gnu/packages/suckless.scm (sbase): New variable.
---

Hi Xinglu,

Not sure how dylanaraps got in that url... :)

Something bugged out or I didn't notice.

Anyways here is version 2 with all of your suggestions. 

Thanks for the review, Much appreciated!

all best,

jgart

 gnu/packages/suckless.scm | 33 +++++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)

Comments

Xinglu Chen Feb. 9, 2022, 1:37 p.m. UTC | #1
Hi,

jgart schrieb am Sonntag der 06. Februar 2022 um 21:17 -05:

> * gnu/packages/suckless.scm (sbase): New variable.
> ---
>
> Hi Xinglu,
>
> Not sure how dylanaraps got in that url... :)
>
> Something bugged out or I didn't notice.
>
> Anyways here is version 2 with all of your suggestions. 
>
> Thanks for the review, Much appreciated!
>
> all best,
>
> jgart
>
>  gnu/packages/suckless.scm | 33 +++++++++++++++++++++++++++++++++
>  1 file changed, 33 insertions(+)
>
> diff --git a/gnu/packages/suckless.scm b/gnu/packages/suckless.scm
> index 708eb2c338..6aedb2b3ba 100644
> --- a/gnu/packages/suckless.scm
> +++ b/gnu/packages/suckless.scm
> @@ -988,6 +988,39 @@ (define-public snooze
>  running a command.")
>      (license license:cc0)))
>  
> +(define-public sbase
> +  ;; There are no tagged releases.
> +  (let ((commit "2c2a7f54ab55a022a617e510b6e00c3e2736fabd")
> +        (revision "0"))
> +    (package
> +      (name "sbase")
> +      (version (git-version "0" revision commit))
> +      (source
> +       (origin
> +         (method git-fetch)
> +         (uri
> +          (git-reference
> +           (url "https://git.suckless.org/sbase/")
> +           (commit commit)))
> +         (file-name (git-file-name name version))
> +         (sha256
> +          (base32 "119v1lpgsx8bx9h57wg454ddhzz2awqavl3wrn35a704vifg28g0"))))
> +      (build-system gnu-build-system)
> +      (arguments
> +       `(#:tests? #f ; There are no tests.
> +         #:make-flags
> +         ,#~(list (string-append "CC=" #$(cc-for-target))
> +                  (string-append "PREFIX=" #$output))
> +         #:phases
> +         (modify-phases %standard-phases
> +           (delete 'configure))))
> +      (home-page "https://core.suckless.org/sbase/")
> +      (synopsis "Collection of unix tools that are portable across
> unix-systems")

“unix” isn’t capitalized.  Whoever merges the patch can probably do it
for you though; no need to send a new reroll.

Otherwise, LGTM.  I didn’t test if all the binaries worked though.
diff mbox series

Patch

diff --git a/gnu/packages/suckless.scm b/gnu/packages/suckless.scm
index 708eb2c338..6aedb2b3ba 100644
--- a/gnu/packages/suckless.scm
+++ b/gnu/packages/suckless.scm
@@ -988,6 +988,39 @@  (define-public snooze
 running a command.")
     (license license:cc0)))
 
+(define-public sbase
+  ;; There are no tagged releases.
+  (let ((commit "2c2a7f54ab55a022a617e510b6e00c3e2736fabd")
+        (revision "0"))
+    (package
+      (name "sbase")
+      (version (git-version "0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri
+          (git-reference
+           (url "https://git.suckless.org/sbase/")
+           (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "119v1lpgsx8bx9h57wg454ddhzz2awqavl3wrn35a704vifg28g0"))))
+      (build-system gnu-build-system)
+      (arguments
+       `(#:tests? #f ; There are no tests.
+         #:make-flags
+         ,#~(list (string-append "CC=" #$(cc-for-target))
+                  (string-append "PREFIX=" #$output))
+         #:phases
+         (modify-phases %standard-phases
+           (delete 'configure))))
+      (home-page "https://core.suckless.org/sbase/")
+      (synopsis "Collection of unix tools that are portable across unix-systems")
+      (description
+  "@command{sbase} is a collection of Unix tools that are portable across
+  Unix-systems.")
+      (license license:x11))))
+
 (define-public scron
   (package
     (name "scron")