diff mbox series

[bug#53673] gnu: Add emacs-beacon.

Message ID 20220206222547.3124928-1-contact@phfrohring.com
State Accepted
Headers show
Series [bug#53673] gnu: Add emacs-beacon. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Pierre-Henry Fröhring Feb. 6, 2022, 10:25 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-beacon): New variable.
---
 gnu/packages/emacs-xyz.scm | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)

Comments

Nicolas Goaziou Feb. 6, 2022, 10:52 p.m. UTC | #1
Hello,

Pierre-Henry Fröhring <contact@phfrohring.com> writes:

> +  (package
> +    (name "emacs-beacon")
> +    (version "1.3.3")

I re-instated version "1.3.4".

> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (string-append "https://elpa.gnu.org/packages/beacon-"
> +                           version ".el"))

I moved origin to GitHub repository instead.

> +       (sha256
> +        (base32 "10r4fpf8pcf1qn5ncpm5g7skzba749mrc1ggykq92jlha3q98s02"))))
> +    (build-system emacs-build-system)
> +    (home-page "https://github.com/Malabarba/beacon")
> +    (synopsis "Emacs minor mode creating a light that follows your cursor around")
> +    (description
> +     "Beacon is an Emacs minor-mode.  Whenever the window scrolls a light will
> +shine on top of your cursor so you know where it is.")
> +    (license license:gpl3+)))

I moved the package definition out of the end of the module and applied
your patch. Thank you.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 8ce245c54a..d717118e65 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -30032,3 +30032,22 @@  (define-public emacs-fennel-mode
      "Fennel mode provides font-lock, indentation, navigation, and REPL for
  Fennel code within Emacs.")
     (license license:gpl3+)))
+
+(define-public emacs-beacon
+  (package
+    (name "emacs-beacon")
+    (version "1.3.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://elpa.gnu.org/packages/beacon-"
+                           version ".el"))
+       (sha256
+        (base32 "10r4fpf8pcf1qn5ncpm5g7skzba749mrc1ggykq92jlha3q98s02"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/Malabarba/beacon")
+    (synopsis "Emacs minor mode creating a light that follows your cursor around")
+    (description
+     "Beacon is an Emacs minor-mode.  Whenever the window scrolls a light will
+shine on top of your cursor so you know where it is.")
+    (license license:gpl3+)))