diff mbox series

[bug#53824] Add the python-databases package.

Message ID 20220206160907.1780570-1-contact@phfrohring.com
State New
Headers show
Series [bug#53824] Add the python-databases package. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Pierre-Henry Fröhring Feb. 6, 2022, 4:09 p.m. UTC
---
 gnu/packages/python-xyz.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)

Comments

Ludovic Courtès March 24, 2022, 10:29 p.m. UTC | #1
Pierre-Henry Fröhring <contact@phfrohring.com> skribis:

> +(define-public python-databases
> +  (package
> +    (name "python-databases")
> +    (version "0.5.5")
> +    (source (origin
> +              (method url-fetch)
> +              (uri (pypi-uri "databases" version))
> +              (sha256
> +               (base32
> +                "0dzb998kg35xmd50ih168320vih2w3ich798r8fc4lf9q4bb1ih2"))))
> +    (build-system python-build-system)
> +    (propagated-inputs (list python-aiocontextvars python-sqlalchemy))
> +    (native-inputs (list python-aiosqlite python-asyncmy python-aiomysql
> +                         python-asyncpg python-aiopg))

All these are presumably used at run time; shouldn’t they be propagated?

Thanks in advance,
Ludo’.
Vagrant Cascadian Sept. 1, 2023, 10:38 p.m. UTC | #2
> +(define-public python-databases
> +  (package
> +    (name "python-databases")
> +    (version "0.5.5")

This was added in:

b4da7c213336342c2f345a45d7b2e9105a893638 gnu: Add python-databases.

And updated in:

8f01f084d33022a0341b98d5d0ec1d93d625846e gnu: python-databases: Update to 0.7.0.

Marking as done.

live well,
  vagrant
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 7c1b5e8ed3..7049ce61fa 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -28931,3 +28931,31 @@  (define-public python-types-dataclasses
      "This packages provides a collection of library stubs for Python, with
 static types.")
     (license license:asl2.0)))
+
+(define-public python-databases
+  (package
+    (name "python-databases")
+    (version "0.5.5")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "databases" version))
+              (sha256
+               (base32
+                "0dzb998kg35xmd50ih168320vih2w3ich798r8fc4lf9q4bb1ih2"))))
+    (build-system python-build-system)
+    (propagated-inputs (list python-aiocontextvars python-sqlalchemy))
+    (native-inputs (list python-aiosqlite python-asyncmy python-aiomysql
+                         python-asyncpg python-aiopg))
+    (home-page "https://github.com/encode/databases")
+    (synopsis "Async database support for Python")
+    (description
+     "Databases gives you simple asyncio support for a
+range of databases.
+
+It allows you to make queries using the SQLAlchemy Core expression language,
+and provides support for PostgreSQL, MySQL, and SQLite.
+
+Databases is suitable for integrating against any async Web framework,
+such as Starlette, Sanic, Responder, Quart, aiohttp, Tornado, or
+FastAPI.")
+    (license license:bsd-3)))