diff mbox series

[bug#53821] Add the python-psycopg2-binary package.

Message ID 20220206153552.1758371-1-contact@phfrohring.com
State Accepted
Headers show
Series [bug#53821] Add the python-psycopg2-binary package. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Pierre-Henry Fröhring Feb. 6, 2022, 3:35 p.m. UTC
`(#:tests? #f)' because tests require a live PostegreSQL instance.

Maxime's suggestions are taken into account in this patch:
  - `(#:tests? #f)' is commented in the code
  - superlatives in the description have been removed
---
 gnu/packages/python-xyz.scm | 36 ++++++++++++++++++++++++++++++++++++
 1 file changed, 36 insertions(+)

2.34.0

Comments

Ludovic Courtès March 24, 2022, 10:23 p.m. UTC | #1
Hi,

Pierre-Henry Fröhring <contact@phfrohring.com> skribis:

> `(#:tests? #f)' because tests require a live PostegreSQL instance.
>
> Maxime's suggestions are taken into account in this patch:
>   - `(#:tests? #f)' is commented in the code
>   - superlatives in the description have been removed
> ---
>  gnu/packages/python-xyz.scm | 36 ++++++++++++++++++++++++++++++++++++
>  1 file changed, 36 insertions(+)
>
> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
> index 7c1b5e8ed3..7b2df04fd2 100644
> --- a/gnu/packages/python-xyz.scm
> +++ b/gnu/packages/python-xyz.scm
> @@ -28931,4 +28931,39 @@ (define-public python-types-dataclasses
>       "This packages provides a collection of library stubs for Python, with
>  static types.")
>      (license license:asl2.0)))
> +
> +(define-public python-psycopg2-binary

Applied with minor tweaks to the synopsis and description and a commit
log that follows our conventions:

  https://guix.gnu.org/manual/devel/en/html_node/Submitting-Patches.html

Thanks, and thank you Maxime!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 7c1b5e8ed3..7b2df04fd2 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -28931,4 +28931,39 @@  (define-public python-types-dataclasses
      "This packages provides a collection of library stubs for Python, with
 static types.")
     (license license:asl2.0)))
+
+(define-public python-psycopg2-binary
+  (package
+    (name "python-psycopg2-binary")
+    (version "2.9.3")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "psycopg2-binary" version))
+              (sha256
+               (base32
+                "0kpaxg3lg5wg5ww5kxmzi2z2d7arsx13ci915d8a2pf17lqza7bn"))))
+    (build-system python-build-system)
+    (native-inputs (list postgresql))
+    (arguments
+     ;; Tests are disable because they need a live instance of PostgreSQL.
+     '(#:tests? #f))
+    (home-page "https://psycopg.org/")
+    (synopsis "Python-PostgreSQL Database Adapter")
+    (description
+     "Psycopg is a PostgreSQL database adapter for the Python programming
+language.  Its main features are the complete implementation of the Python DB
+API 2.0 specification and the thread safety (several threads can share the
+same connection).  It was designed for heavily multi-threaded applications
+that create and destroy lots of cursors and make a large number of concurrent
+“INSERT”s or “UPDATE”s.
+
+Psycopg 2 is mostly implemented in C as a libpq wrapper, resulting in
+being both efficient and secure.  It features client-side and
+server-side cursors, asynchronous communication and notifications,
+“COPY TO/COPY FROM” support.  Many Python types are supported
+out-of-the-box and adapted to matching PostgreSQL data types;
+adaptation can be extended and customized thanks to a flexible objects
+adaptation system.
+
+Psycopg 2 is both Unicode and Python 3 friendly.")
+    (license license:lgpl3+)))
--